Forum: Ruby-Gnome 2 VisualRuby startup fail

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
73eda456fa18b4f23edfd93008d35863?d=identicon&s=25 Ufi Auttorri (ufiauttorri)
on 2016-06-23 18:04
Hi,

I've installed the latest VisualRuby on a win7 x64 machine.  Everything
seemed to install without errors.  Glade launches OK.  However, when
trying to launch vr from the command line I get the following error:

C:\
λ ruby -v
ruby 2.2.2p95 (2015-04-13 revision 50295) [x64-mingw32]

C:\
λ vr
C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/gtk3-3.0.8-x64-mingw32/lib/gtk3/loader.rb:
line 38
   Gdk-CRITICAL **:_gdk_win32_display_create_window_impl: assertion
'display == gdk_display_get_default ()' failed

Does anyone have any ideas on what the problem may be?

Thanks in advance,

Ufi
0d130f179f85401f248e6ebc2ef8292f?d=identicon&s=25 Eric C. (eric_c)
on 2016-06-27 11:01
I don't know.  It should install install the latest versionferom windows
rubtgems,

Eric
0d130f179f85401f248e6ebc2ef8292f?d=identicon&s=25 Eric C. (eric_c)
on 2016-06-27 19:16
Hi:

I tried installing it on my Windows 7 machine and It worked.  It may
have to do with your version of ruby.  I know that there were problems
with Windows and Ruby version 2.0, and I know that it works with 2.3.
So, I'm guessing that the problem was fixed in version 2.3.

I'd try installing ruby v2.3 and see if it fixes the problem.

I will check my exact version when I get home.

Eric
This topic is locked and can not be replied to.