Forum: Ruby on Rails Gem mailcatcher - do not received emails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
5352e063f844eed9d9c2777f20246e31?d=identicon&s=25 Dmitrij B. (dmitrij_b)
on 2015-07-16 16:28
(Received via mailing list)
I create new user. After creating should received confirmation mail. but
when i open mailcatcher(http://127.0.0.1:1080/)... nothing!

i use mailcatcher v. 0.5.12, Rails 3.2.22

In development.rb added:


# Don't care if the mailer can't send
      config.action_mailer.delivery_method = :smtp
      config.action_mailer.smtp_settings = { :address => "localhost",
:port
=> 1025 }
      config.action_mailer.raise_delivery_errors = true



What is wrong with settings? How check error? Please, help, thank you.
75caea9632dfb35b8259dd6e4e4772c6?d=identicon&s=25 Elizabeth McGurty (Guest)
on 2015-07-16 17:22
(Received via mailing list)
I just googled: mailcatcher port smtp.  Found lots of interesting
information.

Seems that your config should read per
http://stackoverflow.com/questions/12554909/using-...

config.action_mailer.smtp_settings = { :address => "127.0.0.1", :port =>
1025 }

Hope this helps
5352e063f844eed9d9c2777f20246e31?d=identicon&s=25 Dmitrij B. (dmitrij_b)
on 2015-07-16 17:43
(Received via mailing list)
i checked with 127.0.0.1.

nothing.

четверг, 16 июля 2015 г., 17:27:45 UTC+3 пользователь Dmitriy написал:
75caea9632dfb35b8259dd6e4e4772c6?d=identicon&s=25 Elizabeth McGurty (Guest)
on 2015-07-16 18:05
(Received via mailing list)
Ummm!  What's in your gemfile?
75caea9632dfb35b8259dd6e4e4772c6?d=identicon&s=25 Elizabeth McGurty (Guest)
on 2015-07-16 18:07
(Received via mailing list)
run gem list
77992aff3f9080a5ab1cc3edeef039da?d=identicon&s=25 Fernando Kakimoto (Guest)
on 2015-07-16 18:21
(Received via mailing list)
Hi Dmitriy.

Do you use background jobs to send emails? If so, you probably need to
start them in development.

Take a look at your test/development.log and check if email is actually
being sent. Maybe that should help figuring out the issue.

Cheers,
Fernando


On Thu, Jul 16, 2015 at 1:06 PM, Elizabeth McGurty <emcgurty2@gmail.com>
wrote:

>>>
>
<https://groups.google.com/d/msgid/rubyonrails-talk...
> .
>
> For more options, visit https://groups.google.com/d/optout.
>



--
Fernando Kakimoto
http://www.twitter.com/nandokakimoto
Bee69cfed999cd13e3bff73d472a39ee?d=identicon&s=25 Hassan Schroeder (Guest)
on 2015-07-16 18:55
(Received via mailing list)
On Thu, Jul 16, 2015 at 7:27 AM, Dmitriy <d.borowskij@gmail.com> wrote:

> In development.rb added:

>       config.action_mailer.delivery_method = :smtp
>       config.action_mailer.smtp_settings = { :address => "localhost", :port
> => 1025 }
>       config.action_mailer.raise_delivery_errors = true

In development mode, the default is to *not* actually send mails, so
you need to change that:

         config.action_mailer.perform_deliveries = true

HTH,
--
Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
http://about.me/hassanschroeder
twitter: @hassan
Consulting Availability : Silicon Valley or remote
This topic is locked and can not be replied to.