Forum: Italian Ruby user group SOLR sunspot - errore in production - reindex

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
C26e692d4d3de5881ebb873409085768?d=identicon&s=25 Roberto Sacchetti (ikaiser)
on 2015-05-13 10:35
Ciao a tutti,
innanzitutto vi ringrazio per ogni forma di aiuto,
vado a l problema:

ho installato e configurato SOLR nel mio ENVIRONMENT di development e
tutto
funziona egregiamente, vado a clonare il tutto in production e ho due
errori il primo:

lancio questo comando:
bundle exec rake sunspot:solr:reindex RAILS_ENV=production --trace

e questo è lo stack trace:

** Invoke sunspot:solr:reindex (first_time)
** Invoke sunspot:reindex (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute sunspot:reindex
Error using progress bar: Max must be a positive integer
rake aborted!
RSolr::Error::Http: RSolr::Error::Http - 404 Not Found
Error:     Not Found

URI: http://localhost:8982/solr/production/update?wt=ruby
Request Headers: {"Content-Type"=>"text/xml"}
Request Data: "<?xml version=\"1.0\"
encoding=\"UTF-8\"?><delete><query>type:Announcement</query></delete>"
... ...

non riesco a comprendere il perche non indicizzi i miei annunci.

grazie mille per l'aiuto.
32d80da41830a6e6c1bb3eb977537e3e?d=identicon&s=25 Alessandro R. (alessandro_r)
on 2015-05-13 10:52
(Received via mailing list)
Com'e' la configurazione di sunspot? Ovvero sunspot.yml? Puoi provare a
sostituire /solr/production con /solr/default?

Alessandro Rodi

2015-05-13 10:35 GMT+02:00 Roberto Sacchetti
<info@robertosacchetti.com>:
C26e692d4d3de5881ebb873409085768?d=identicon&s=25 Roberto Sacchetti (ikaiser)
on 2015-05-13 14:22
questa è la configurazione di SOLR: e avendo cambiato in default

production:
  solr:
    hostname: localhost
    port: 8983
    log_level: WARNING
    path: /solr/default
    # read_timeout: 2
    # open_timeout: 0.5

development:
  solr:
    hostname: localhost
    port: 8982
    log_level: INFO
    path: /solr/development

test:
  solr:
    hostname: localhost
    port: 8981
    log_level: WARNING
    path: /solr/test

ora dovrei aver risolto.

dovevo inserire un prodotto test per fare il reindex e poi elimanrlo.

Grazie MIlle.
This topic is locked and can not be replied to.