Forum: JRuby How do I fix RuntimeException: callback-style handles are no longer supported in JRuby?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
38cc7360c986d10ba0c45db8f2b52148?d=identicon&s=25 Laura B. (laura_b)
on 2015-02-04 16:18
I am using jdk 1.8, but I have errors with the jruby code
concerning collections and sorting. I had jruby 1.6.3, so I upgraded to
jruby 1.7.19.  But now I can't run the rake db:migrate command. I get
this error:

rake aborted!
load error: fast_xs -- java.lang.RuntimeException: callback-style
handles are no longer supported in JRuby

So I have 2 questions:
Which version of jruby should I use with jdk 1.8?
What does the exception "callback-style handles are no longer supported
in JRuby" mean? I'm not sure to what it is referring.

Thanks in advance for your help.
Bee69cfed999cd13e3bff73d472a39ee?d=identicon&s=25 Hassan Schroeder (Guest)
on 2015-02-05 00:04
(Received via mailing list)
On Wed, Feb 4, 2015 at 7:18 AM, Laura B. <lists@ruby-forum.com> wrote:
> Which version of jruby should I use with jdk 1.8?
I just tried a combination of Rails 4.1.9, JRuby 1.7.19 on a Centos7
Vagrant box with a freshly downloaded Java version "1.8.0_31".

No problems creating an app and running migrations with the default
SQLite3.

Can you tell us more: OS, Rails version, DB, maybe gist the Gemfile?

--
Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
http://about.me/hassanschroeder
twitter: @hassan
Consulting Availability : Silicon Valley or remote
38cc7360c986d10ba0c45db8f2b52148?d=identicon&s=25 Laura B. (laura_b)
on 2015-02-05 18:02
I am running on Windows 7, using postgres DB, and the rails gem is
3.1.3. I installed the rails 4.1.9 gem, but when I tried the rake
command again, it said it could not find rails-3.1.3, and said I should
do bundle install, which I did.
This is now my list of gems:
actionmailer (4.1.9, 3.1.3)
actionpack (4.1.9, 3.1.3)
actionview (4.1.9)
activemodel (4.1.9, 3.1.3)
activerecord (4.1.9, 3.1.3)
activerecord-jdbc-adapter (1.2.2)
activerecord-jdbcpostgresql-adapter (1.2.2)
activeresource (3.1.3)
activesupport (4.1.9, 3.1.3)
addressable (2.2.8)
arel (5.0.1.20140414130214, 2.2.3)
axiom-types (0.1.1)
bouncy-castle-java (1.5.0146.1)
builder (3.2.2, 3.0.0)
bundler (1.7.12)
capybara (1.1.2)
childprocess (0.3.2)
coercible (1.0.0)
descendants_tracker (0.0.4)
diff-lcs (1.1.3)
equalizer (0.0.9)
erubis (2.7.0)
factory_girl (2.6.4)
ffi (1.9.3 java, 1.0.11 java)
flay (1.4.2)
flog (2.5.1)
haml (3.1.4)
haml-rails (0.3.4)
hike (1.2.1)
hpricot (0.8.6 java)
i18n (0.7.0, 0.6.0)
ice_nine (0.11.1)
jar-dependencies (0.1.2)
jdbc-postgres (9.1.901)
jruby-jars (1.7.19, 1.6.5)
jruby-openssl (0.9.5 java, 0.7.6.1)
jruby-rack (1.1.4)
jruby-win32ole (0.8.5)
json (1.8.0 java, 1.6.6 java)
krypt (0.0.2)
krypt-core (0.0.2 universal-java)
krypt-provider-jdk (0.0.2)
libwebsocket (0.1.3)
mail (2.6.3, 2.3.3)
maven-tools (1.0.7)
mime-types (1.18)
minitest (5.5.1)
multi_json (1.2.0)
nokogiri (1.5.2 java)
polyglot (0.3.3)
rack (1.5.2, 1.3.6)
rack-cache (1.2)
rack-mount (0.8.3)
rack-ssl (1.3.2)
rack-test (0.6.3, 0.6.1)
rails (4.1.9, 3.1.3)
rails_code_qa (0.5.0)
railties (4.1.9, 3.1.3)
rake (10.1.0, 0.9.2.2)
rcov (0.9.9 java)
rdoc (4.1.2, 3.12)
rsolr (1.0.7)
rsolr-ext (1.0.3)
rspec (2.10.0)
rspec-core (2.10.1)
rspec-expectations (2.10.0)
rspec-mocks (2.10.1)
rspec-rails (2.10.1)
ruby-maven (3.1.1.0.8)
ruby-maven-libs (3.1.1)
ruby_parser (2.3.1)
rubyzip (0.9.6.1)
selenium-webdriver (2.22.0)
sexp_processor (3.1.0)
simplecov (0.6.4)
simplecov-html (0.5.3)
sprockets (2.12.3, 2.0.3)
sprockets-rails (2.2.4)
thor (0.19.1, 0.14.6)
thread_safe (0.3.4 java)
tilt (1.3.3)
treetop (1.4.10)
tzinfo (1.2.2, 0.3.32)
uuidtools (2.1.2)
virtus (1.0.4)
warbler (1.3.2)
will_paginate (3.0.3)
xpath (0.1.4)

Thanks.
Bee69cfed999cd13e3bff73d472a39ee?d=identicon&s=25 Hassan Schroeder (Guest)
on 2015-02-05 18:27
(Received via mailing list)
On Thu, Feb 5, 2015 at 9:02 AM, Laura B. <lists@ruby-forum.com> wrote:
> I am running on Windows 7, using postgres DB, and the rails gem is
> 3.1.3. I installed the rails 4.1.9 gem, but when I tried the rake
> command again, it said it could not find rails-3.1.3, and said I should
> do bundle install, which I did.
> This is now my list of gems:

Um, well. That's a lot of variables :-)

I would try creating a simpler test case that demonstrates the issue,
e.g. `rails new defaults` and see if that fails in your environment. If
not, add gems to it individually and see if/when the failure appears.

--
Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
http://about.me/hassanschroeder
twitter: @hassan
Consulting Availability : Silicon Valley or remote
This topic is locked and can not be replied to.