Forum: Ruby on Rails Am i missing a library?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
C811c6c9b547164fbbdabf545cc46a81?d=identicon&s=25 Adam (Guest)
on 2006-06-08 21:09
[xxxxx@fedora test]$ script/generate model contact
/usr/lib/ruby/1.8/yaml.rb:133:in `load': syntax error on line 17, col 2:
`  host: localhost' (ArgumentError)
        from /usr/lib/ruby/1.8/yaml.rb:133:in `load'
        from
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:459:in
`database_configuration'
        from
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:181:in
`initialize_database'
        from
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:84:in
`process'
        from
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:42:in `run'
        from ./script/../config/../config/environment.rb:13
        from /usr/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/commands/generate.rb:1
        from /usr/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
`require'
        from script/generate:3
12f219699d6bee06c8ac08455065446f?d=identicon&s=25 David Andersen (Guest)
on 2006-06-08 22:41
(Received via mailing list)
just a typo in your database.yml

d.
27031aa98cdc9939a2ce990d7a4eeefa?d=identicon&s=25 JuanWalker (Guest)
on 2006-06-19 05:00
David Andersen wrote:
> just a typo in your database.yml
>
> d.

Dont`t forget separate each label from values, i mean

user: *********
database: *******
password: *******

A TIPO
This topic is locked and can not be replied to.