Forum: Ruby problem with btpgsql

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
6d049228e70f6828ebdc5d7b30667748?d=identicon&s=25 Eduardo Borges (Guest)
on 2006-06-01 17:54
(Received via mailing list)

I foll the readme instructions, but I had a problem in the btpgsql
I don't know how resolve this problem. Can Anybody help me, please?
Sorry about the English.   :-)

~/btpgsql-0.2.4# ruby test/all.rb

test/all.rb:43: warning: don't put space before argument parentheses
RUNNING TEST test/btpgsql.rb
./lib/btpgsql/btpgsql.rb:1567: warning: don't put space before
argument parentheses
./lib/btpgsql/arrayfields.rb:1:in `require': no such file to load --
arrayfields.rb (LoadError)
        from ./lib/btpgsql/arrayfields.rb:1
        from ./lib/btpgsql/btpgsql.rb:51
        from ./lib/btpgsql.rb:1
        from ./test/btpgsql.rb:52
        from test/all.rb:49
        from test/all.rb:47

~/btpgsql-0.2.4# ruby install.rb
install.rb:15:in `=~': type mismatch: String given (TypeError)
        from install.rb:15

I am using Slackware 10.2 with the pre-compiled package
ruby-1.8.4-i686-1kjz.tgz. I have compiled and installed the package
ruby-postgres-20051221.tar.gz witch is a requeriment.

Please HELP!

Tank you!
Cb48ca5059faf7409a5ab3745a964696?d=identicon&s=25 unknown (Guest)
on 2006-06-01 18:02
(Received via mailing list)
On Fri, 2 Jun 2006, Eduardo Borges wrote:

> ./lib/btpgsql/btpgsql.rb:1567: warning: don't put space before
> ~/btpgsql-0.2.4# ruby install.rb
> --
> Eduardo Nunes Borges
> Engenheiro de Computação - FURG
> Mestrando em Computação - UFRGS

hey edurado-

i haven't updated that package for quite some time.  however, the
problem you
are having is not related to that, but to the fact that you don't have
arrayfields installed.  it's also on codeforpeople

feel free to contact my on or offline with questions regarding btpgsql.



6d049228e70f6828ebdc5d7b30667748?d=identicon&s=25 Eduardo Borges (Guest)
on 2006-06-10 00:49
(Received via mailing list)
I installed the arrayfields, but not resolv the problem.

btpgsql-0.2.4# ruby install.rb
install.rb:14:in `=~': type mismatch: String given (TypeError)
        from install.rb:14

I remove the lines below from the install.rb and I think that it works.

if !$site_libdir
  $site_libdir = File.join($libdir, "site_ruby")
elsif $site_libdir !~ Regexp.quote($version)
  $site_libdir = File.join($site_libdir, $version)

After I run

btpgsql-0.2.4# ruby install.rb
lib/btpgsql/btpgsql.rb ->
chmod 0644 /usr/local/lib/ruby/site_ruby/btpgsql/btpgsql.rb
lib/btpgsql/arrayfields.rb ->
chmod 0644 /usr/local/lib/ruby/site_ruby/btpgsql/arrayfields.rb
lib/btpgsql/quote.rb -> /usr/local/lib/ruby/site_ruby/btpgsql/quote.rb
chmod 0644 /usr/local/lib/ruby/site_ruby/btpgsql/quote.rb
lib/btpgsql/VERSION -> /usr/local/lib/ruby/site_ruby/btpgsql/VERSION
chmod 0644 /usr/local/lib/ruby/site_ruby/btpgsql/VERSION
lib/btpgsql/btpgsql.rb.orig ->
chmod 0644 /usr/local/lib/ruby/site_ruby/btpgsql/btpgsql.rb.orig

I hope it had worked.

Tanks for the help, and sorry about my English.

Eduardo Nunes Borges
Engenheiro de Computação - FURG
Mestrando em Computação - UFRGS

2006/6/1, <>:
This topic is locked and can not be replied to.