Forum: Ruby on Rails In Place Editor Fields and Safari

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
12be02204a4bcaeec2c6c369fe53a45b?d=identicon&s=25 Dave Hoefler (Guest)
on 2006-05-23 18:02
(Received via mailing list)

Does anyone else have any problems with Safari and in place editor
I'm specifically talking about trying to save a null value in a text
box. In
Firefox/IE/Camino/etc... saving a null value from an in place editor
how it's supposed to. If the value is null, then 'click to edit' is
displayed. However with Safari when a null value is saved, Safari seems
get stuck on "Saving..." and doesn't display 'click to edit' unless a
refresh is done.

Is there a fix or hack for this?

Thank you,
Dave Hoefler
30ee518e6fdc5b07e060775b5a542bdb?d=identicon&s=25 Jón Borgþórsson (jongretar)
on 2006-05-23 18:09
(Received via mailing list)
Try downloading WebKit (Safari Beta).
and see if the have fixed it.
Safari has had some limitations with inline editing.
If it still doesn't work try submitting it. They are working on fixing
little things like that.

On 5/23/06, Dave Hoefler <> wrote:
> Is there a fix or hack for this?
12be02204a4bcaeec2c6c369fe53a45b?d=identicon&s=25 Dave Hoefler (Guest)
on 2006-05-23 18:37
(Received via mailing list)
Hi Jon... thanks for the link. I tried WebKit and that didn't fix the
'saving...' issue. Before I submit a bug, is anyone else having such an
issue with Safari or am I the only one?

Dave Hoefler
This topic is locked and can not be replied to.