Forum: Ruby on Rails capistrano and svn+ssh on non-standard port

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
2604f71d2251ec1acaa8ce7078a8849f?d=identicon&s=25 unknown (Guest)
on 2006-05-17 23:34
(Received via mailing list)
Hi,

I have ssh configured with a non-standard port, and I use svn+ssh to
access to my repository. As the svn+ssh protocol doesn't support the
colon convention to specify the port, I export the SVN_SSH variable in
.bashrc, like this...
SVN_SSH="ssh -p 2323"

Now I can do a checkout from the command like using something like
this...

svn checkout  svn+ssh://xx.xxx.com/path/to/trunk

It works. But now I try to use this configuration in Capistrano, by
setting...

set :repository, "svn+ssh://xx.xxx.com/path/to/trunk"
ssh_options[:port] = 2323

I'm running Capistrano with the user account that has the SVN_SSH
defined in .bashrc, and it doesn't work. I'm getting an error like this
when trying to deploy

   [xx.xxx.com] executing command
  ** [out :: xx.xxx.com] ssh: connect to host xxx.xxx.com port 22:
Connection refused
  ** [out :: xx.xxx.com] svn: Connection closed unexpectedly

Does anyone has any idea on which could be the problem, and/or how to
solve it?

Thanks in advance.

xavi
2604f71d2251ec1acaa8ce7078a8849f?d=identicon&s=25 unknown (Guest)
on 2006-05-18 21:02
(Received via mailing list)
I've solved it!

This is how I did it:
I've removed the SVN_SSH environment variable that I had in my .bashrc,
and instead I've indicated the non-standard port in
~/.subversion/config, adding the following line in the [tunnels]
section:

ssh = $SVN_SSH ssh -p 2323


Cheers,

xavi
This topic is locked and can not be replied to.