Forum: Ruby Ruby 1.8.4 fails install with Autoconf 2.59c

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
E347160720308f5a8a30b354642c4769?d=identicon&s=25 Igor (Guest)
on 2006-05-16 15:59
I updated Autoconf 2.59c today to autoconf Ruby 1.8.4 (I ve got it
through CVS)
I am getting an error when trying to make it:

==============================
root@... [/..../ruby-1.8.4]# make
gcc main.o  libruby-static.a -ldl -lcrypt -lm   -o miniruby -g -O2
-DRUBY_EXPORT   -rdynamic -Wl,-export-dynamic
rbconfig.rb unchanged
compiling Win32API
make[1]: Entering directory `/..../ruby-1.8.4/ext/Win32API'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/..../ruby-1.8.4/ext/Win32API'
compiling bigdecimal
make[1]: Entering directory `/..../ruby-1.8.4/ext/bigdecimal'
Makefile:140: *** missing separator.  Stop.
make[1]: Leaving directory `/..../ruby-1.8.4/ext/bigdecimal'
make: *** [all] Error 1
===============================

I re-checked `/..../ruby-1.8.4/ext/bigdecimal/Makefile at line 140
It seems that everything is normal (all tabs no spaces)

During ./configure it ended with the following:
(I am not sure if this crusial)

===============================
configure: creating ./config.status
config.status: creating Makefile
config.status: WARNING:  Makefile.in seems to ignore the --datarootdir
setting
===============================

My night is gone and I am desperate.
Plese, help!
E347160720308f5a8a30b354642c4769?d=identicon&s=25 Igor (Guest)
on 2006-05-16 16:56
> During ./configure it ended with the following:
> (I am not sure if this crusial)
>
> ===============================
> configure: creating ./config.status
> config.status: creating Makefile
> config.status: WARNING:  Makefile.in seems to ignore the --datarootdir
> setting
> ===============================

I found this post
http://www.mail-archive.com/automake@gnu.org/msg11356.html

They suggested that I have to edit file:
# edit Makefile.in

and edd there the following line manually:

datarootdir = @datarootdir@

Now one more error gone.
Still can't make a build.
E347160720308f5a8a30b354642c4769?d=identicon&s=25 Igor (Guest)
on 2006-05-16 17:17
> make[1]: Entering directory `/..../ruby-1.8.4/ext/bigdecimal'
> Makefile:140: *** missing separator.  Stop.

I roll back to Autoconfig 2.58 and everything went smoothly.
Problem solved but for future upgrades could be a problem
0ec4920185b657a03edf01fff96b4e9b?d=identicon&s=25 Yukihiro Matsumoto (Guest)
on 2006-05-17 01:42
(Received via mailing list)
Hi,

In message "Re: Ruby 1.8.4 fails install with Autoconf 2.59c"
    on Wed, 17 May 2006 00:17:50 +0900, Igor <igor@anatsko.com> writes:

|> make[1]: Entering directory `/..../ruby-1.8.4/ext/bigdecimal'
|> Makefile:140: *** missing separator.  Stop.
|
|I roll back to Autoconfig 2.58 and everything went smoothly.
|Problem solved but for future upgrades could be a problem

I think it's a compatibility issue for autoconf2.59.  Could someone
report this issue to the autoconf maintainers?

							matz.
This topic is locked and can not be replied to.