Forum: Ruby on Rails Apache 1.3 Ruby on Rails (Slackware 10.2)

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
25798ded15ac53e8e3b4ab66511af74d?d=identicon&s=25 Andreas Grandin (granden)
on 2006-05-13 17:03
Hi,
Im new to Ruby on Rails, it seems to be really powerfull.
I am running Apache 1.3.x and I dont know how to set it up to work with
Ruby on Rails.
I think the problem is Fast CGI because I dont understand how to set
that up.
I can't find anything regarding Fast-CGI in my apache config file. But I
find this its some sort of cgi.
LoadModule cgi_module         libexec/apache/mod_cgi.so
AddModule mod_cgi.c
A5aa88cb70b8afb8511b1e77dd57964f?d=identicon&s=25 Andy Churchstone (andy)
on 2006-05-13 23:11
Andreas Grandin wrote:
> Hi,
> Im new to Ruby on Rails, it seems to be really powerfull.
> I am running Apache 1.3.x and I dont know how to set it up to work with
> Ruby on Rails.
> I think the problem is Fast CGI because I dont understand how to set
> that up.
> I can't find anything regarding Fast-CGI in my apache config file. But I
> find this its some sort of cgi.
> LoadModule cgi_module         libexec/apache/mod_cgi.so
> AddModule mod_cgi.c

I had Apache 1.3.x and MySQL 3.23.x until a few hours ago.

I think you should upgrade to Apache 2 and then proxy to something (e.g.
Lighty/Mongrel) or switch to Lighttpd altogether as this is what the
wiser beings are suggesting for stability reasons.

I just now installed Apache 2 so that both 2.2.2 and 1.3.x are running
alongside each other on different ports. MySQL is also now 5.0.21. I
have set up the Apache 2.2.2 installation to proxy to Lighttpd and all
that works great. The good thing is that I can mess around with the
whole Apache 2/Lighttpd stuff at my leisure using the designated port
for it, and the old site continues to tick away on Port 80. When I've
finally got everything sorted, I'll make Apache 2 the main webserver.

If you do intend on using FastCGI with Apache 1.3.x anyway, I think the
module you need to enable in httpd.conf is mod_fastcgi, followed by an
Apache restart.
A5aa88cb70b8afb8511b1e77dd57964f?d=identicon&s=25 Andy Churchstone (andy)
on 2006-05-13 23:13
In fact.. just checked my Apache 1.3.x httpd.conf and to be more exact,
the line you are looking for is:

LoadModule fastcgi_module     libexec/mod_fastcgi.so
This topic is locked and can not be replied to.