Forum: GNU Radio Problem with making sound card as source

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
908b26698752d141fda4c93e5ce45d9e?d=identicon&s=25 2 1 (Guest)
on 2006-05-09 14:36
(Received via mailing list)
Hi, all

My USRP is on delievering, so I try to do someting with the sound card.

Unfortunately, the integrated AC97 sound card of my pc seem to not work
properly as source.
I connect a mp3 player with the line-in port of sound card with an audio
wire.
In a script, the sound card is set to source and connected to a file
sink,
so the sampled raw audio is written to a file.
In another script, the raw audio file is set to the source and replayed
by
the sound card as sink.
But, I hear nothing from my sound card.

The dialtone.py can work making the sound properly, so the sound card as
sink is ok.

Hanwen
3596cfe1d579c65b9babd35e8787977c?d=identicon&s=25 Matt Ettus (Guest)
on 2006-05-09 18:29
(Received via mailing list)
Can you record sound in other applications?  Have you set the audio
mixer properly?

Matt


On Tue, 2006-05-09 at 20:34 +0800, 2 1 wrote:
> sink, so the sampled raw audio is written to a file.
> Discuss-gnuradio@gnu.org
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
--
Matt Ettus <matt@ettus.com>
908b26698752d141fda4c93e5ce45d9e?d=identicon&s=25 2 1 (Guest)
on 2006-05-10 14:15
(Received via mailing list)
Hi, Matt :)

I do set the line-in as the record source in the mixer. But I found that
the
audio recorder app of my FC4 can't record either. I'm doubt that the
sound
drive of FC4 cannot support the card well. Besides, I tried on 3
different
machines and all of them failed. They all have a intel integrated sound
card. I'm using gr-audio-alsa.0.3.tar.gz.

Have you ever met this problem before? And do you know how to make the
sound
card well supported under linux?

Thanks a lot.

Hanwen

2006/5/10, Matt Ettus <matt@ettus.com>:
C64c1417762c07a7587efc9af476f1bd?d=identicon&s=25 Brett L Trotter (Guest)
on 2006-05-10 15:32
(Received via mailing list)
I had a similar problem- turned out not to be the hardware.
Run alsamixer and make sure to turn on capture on your line input (with
spacebar) and turn up the volume all the way, then turn on capture on
capture and turn the volume up all the way again. You should then be
getting audio and adjust the volume down to reduce clipping.
908b26698752d141fda4c93e5ce45d9e?d=identicon&s=25 2 1 (Guest)
on 2006-05-15 05:29
(Received via mailing list)
Thanks Breett:) I've solved this problem by turn on capture item in the
mixer. And I guess that's why there are many people say that there linux
cannot recording sound.

Hanwen

2006/5/10, Brett L Trotter <brett@silcon.com>:
This topic is locked and can not be replied to.