Forum: Ruby on Rails RSS Feed / xml.link problem?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
3319ab6fb19fcf97c8a3d66b8a9b68bf?d=identicon&s=25 Josh on Rails (Guest)
on 2006-05-08 16:44
(Received via mailing list)
I'm having an odd problem. I'm trying to create an RSS feed (working off
the
Recipe), but "xml.link" generates error about "Can't convert Hash to
String". From the error trace, it *looks* like it's calling the a
fileutil
'link' method (as in, filesystem symbolic link) - even xml.tag!
generates
this error.

Er, how do I make it stop?

Here's the full error:

can't convert Hash into String
> RAILS_ROOT: script/../config/..
>
Thanks!
3319ab6fb19fcf97c8a3d66b8a9b68bf?d=identicon&s=25 Josh on Rails (Guest)
on 2006-05-08 17:28
(Received via mailing list)
So, I thought I'd out-smart this problem: I grabbed FeedTools. But I'm
still
getting this error there (though, only at the point where I build the
xml -
so, the link goes into the feed object alright, but gets odd somewhere
during the build?)


-- Joshua
3319ab6fb19fcf97c8a3d66b8a9b68bf?d=identicon&s=25 Josh on Rails (Guest)
on 2006-05-08 18:33
(Received via mailing list)
Just updating myself... In case other people have this problem, I
suppose...
This problem does not appear on my debian box, but does appear on my
Windows
machine.
784f760ee2b30a896cefabd91cdf0dba?d=identicon&s=25 Bob Aman (Guest)
on 2006-05-08 19:22
(Received via mailing list)
> So, I thought I'd out-smart this problem: I grabbed FeedTools. But I'm still
> getting this error there (though, only at the point where I build the xml -
> so, the link goes into the feed object alright, but gets odd somewhere
> during the build?)

Is this what you tried?

require 'rubygems'
require 'feed_tools'

feed = FeedTools::Feed.new
feed.title = @city.name + ' RailsPubNite Events'
feed.link = "test doodad?"
feed.build_xml('rss', 2.0)

Because that worked just fine for me.

Cheers,
Bob Aman
--
AIM: sporkmonger
Jabber: sporkmonger@jabber.org
024e4717cdf03bb03179a9594805431d?d=identicon&s=25 Pat Lynch (Guest)
on 2006-05-09 03:01
(Received via mailing list)
Hi,
I put this on the forum.but perhaps one of you can help me solve this
problem.but the problem has been on it for about 5 months and still no
real answer.

On page 57 in the book "Agile Web Development with Rails" there is the
following command:
"ruby script/generate scaffold Product Admin"
When I invoke it, I get the following error message:
"#28000 access denied for user 'root'@'localhost' using password [NO]"

I'd appreciate any help.

Thanks,
Pat
D90ef6808433e63203e15a5c2dadb0bb?d=identicon&s=25 Ben Reubenstein (Guest)
on 2006-05-09 03:01
(Received via mailing list)
Your database is not configured properly.  Rails cannot access it.
Check your database.yml file and database user/pass settings.

~Ben

On 5/8/06, Pat Lynch <lynchnco@patmedia.net> wrote:
>
>
> http://lists.rubyonrails.org/mailman/listinfo/rails
>
>
>


--
Ben Reubenstein
303-947-0446
http://www.benr75.com
024e4717cdf03bb03179a9594805431d?d=identicon&s=25 Pat Lynch (Guest)
on 2006-05-09 03:10
(Received via mailing list)
Hi,

Thanks for responding...

I set the Database.yml file to those given by the author on page 56 in
Figure 6.1.

I couldn't grant permissions using the procedures shown by the author on
pg 54.

I'll delete the database and try again...

Wish me luck,
Pat
40db9e75b3f5899258e3bdc0c9210154?d=identicon&s=25 Conrad Taylor (Guest)
on 2006-05-09 03:35
(Received via mailing list)
Hey Pat, when you see this type of error message, it means that you
need to add a password for you database.  Thus, you'll enter the
password
for root and you should be good to go.

Peace,

-Conrad
024e4717cdf03bb03179a9594805431d?d=identicon&s=25 Pat Lynch (Guest)
on 2006-05-09 03:57
(Received via mailing list)
Hi,
I'm using the book "Agile Web Development with Rails".
The author had me change database.yml, on page 56 [fig 6.1].

I tried going back to the original yml file and added a password for
root.but I still get the same error.

On page 54, when I tried the following command:
Grant all on depot_development.* to 'dave'@'localhost';
I get the following error:
Error 1133(42000): Can't find any matching row in the user table.

I'm stumped.it just can't possibly be this difficult.

Help,
Pat
This topic is locked and can not be replied to.