Forum: Ruby on Rails WEBrick initialisation problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
28ca850f75008d8790514a65477cbf72?d=identicon&s=25 Brian Watson (misterb)
on 2006-05-04 09:08
I am new to Ruby so I thought the best way to get into it would be to
follow the ONLamp "Rolling with Ruby on Rails" intro. I followed the
instructions to the letter and everything work just great, very
impressive:-).

A couple of days later when I went back to it I got the following
message when trying to start the WEBrick server.

U:\RoRProjects\cookbook>ruby script\server => Booting WEBrick...
=> Rails application started on http://0.0.0.0:3000 => Ctrl-C to
shutdown server; call with --help for options
[2006-05-03 08:52:40] INFO  WEBrick 1.3.1
[2006-05-03 08:52:40] INFO  ruby 1.8.4 (2005-12-24) [i386-mswin32]
[2006-05-03 08:52:40] WARN  TCPServer Error: Bad file descriptor -
bind(2)
u:/ruby/lib/ruby/1.8/webrick/utils.rb:73:in `initialize': Bad file
descriptor - bind(2) (Errno::EBADF)
        from u:/ruby/lib/ruby/1.8/webrick/utils.rb:73:in
`create_listeners'

I have tried totally uninstalling (ruby, rails, MySQL) and then
reinstalling but with no success. Obviously something has changed in the
environment that it is running in but I cannot recall anything that has
been done that would be of significance. I submitted this to the Ruby
mailing list and Eric Hodel suggest I try the following:

U:\ruby>ruby -rsocket -e "TCPServer.new 'localhost', 3000"

which proved there's nothing already running on port 3000. Any
suggestions would be gratfuly received.
Ed097d0e34ab5e7e4e986c05da2e8e40?d=identicon&s=25 anup (Guest)
on 2006-05-05 09:21
(Received via mailing list)
See if another Webrick instance is running on port 3000.
See the following tutorial to shutdown:
http://kriskhaira.com/blog/138/how-to-shut-down-an...

I think this wud help
This topic is locked and can not be replied to.