Forum: Ferret Locale not set error when trying to use C version in a rails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Eca15b2b601e7e577d38bd5210a753ac?d=identicon&s=25 Carl Youngblood (Guest)
on 2006-05-03 19:10
(Received via mailing list)
I'm getting a locale not set error.  Does anyone know how I should set
my locale in my rails environment so that ferret knows what to do?
Why isn't this a problem in the ruby version of ferret?

Thanks,
Carl
E48d29dc8fedb2878fa518d41cc63d88?d=identicon&s=25 Jan Prill (Guest)
on 2006-05-13 16:59
Carl Youngblood wrote:
> I'm getting a locale not set error.  Does anyone know how I should set
> my locale in my rails environment so that ferret knows what to do?
> Why isn't this a problem in the ruby version of ferret?
>
> Thanks,
> Carl

Hi, Carl,

have you had success in ruling out this issue?

While I was fiddling around with ferret 0.9.3 while testing for
http://ferret.davebalmain.com/trac/wiki/MyFirstBenchmark I had problems
with the set locale on a gentoo box.

This happened to be a problem of the c-analyzer to read documents with
special characters on my installation. The encoding was posix and I had
to change it to de_DE or us_US to index project gutenberg files. On
gentoo linux this was done with "locale -a" to check out the possible
locales and after that setting one of these locales by "export LANG =
de_DE", "export LC_ALL = de_DE" and so on. Afterwards I changed the
locale of the whole system to Unicode by changing /etc/env.d/02locale.
This is on gentoo, you need to check out how it is on your distro.
ymmv...

Regards
Jan
C9dd93aa135988cabf9183d3210665ca?d=identicon&s=25 Jens Kraemer (Guest)
on 2006-08-03 14:22
(Received via mailing list)
On Sat, Apr 29, 2006 at 07:38:23PM -0600, Carl Youngblood wrote:
> I'm getting a locale not set error.  Does anyone know how I should set
> my locale in my rails environment so that ferret knows what to do?

try setting ENV['LANG']='en_US.UTF-8' in your environment.rb. That
worked for me.

> Why isn't this a problem in the ruby version of ferret?

I have no idea...

Jens

--
webit! Gesellschaft für neue Medien mbH          www.webit.de
Dipl.-Wirtschaftsingenieur Jens Krämer       kraemer@webit.de
Schnorrstraße 76                         Tel +49 351 46766  0
D-01069 Dresden                          Fax +49 351 46766 66
Eca15b2b601e7e577d38bd5210a753ac?d=identicon&s=25 Carl Youngblood (Guest)
on 2006-08-03 14:22
(Received via mailing list)
Thanks.  I tried that after an online search (before receiving your
response) and it worked.
This topic is locked and can not be replied to.