Forum: Rails France Utiliser RadRails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
05ab66b795a2cbdffc97d2b8209e3a6b?d=identicon&s=25 Thomas Bassetto (Guest)
on 2006-04-28 19:35
(Received via mailing list)
Bonjour,

J'ai acheté récemment le livre "Ruby On Rails" des Éditions Eyrolles
et j'ai réussi à coder et faire tourner leur exemple de e-commerce.
J'ai fait ça sous Ubuntu Dapper et gEdit...

Maintenant j'ai voulu installer RadRails. J'ai donc installé Eclipse
via Synaptic. Mais après je me suis rendu sur le site de radrails,
j'ai téléchargé l'archive et j'ai lancé radrails directement via
l'exécutable qui se trouvait à l'intérieur.

On m'avait pourtant dit de :
"Pour l'installer, il suffit, depuis Eclipse, d'aller dans Help >
Software Updates > Find and Install > Search for new features to
install et de rentrer un nouveau dépôt en cliquant sur New remote site
et en saisissant ces informations :

Name : RadRails
URL : http://radrails.sourceforge.net/update"

Est-ce que ça reviens au même ? Car si je fais la deuxième méthode,
Eclipse me sors qu'il me manque un plu-gin rubypeople....

De toute façon, je cherche un tuto pour se servir de RadRails car
c'est un peu déroutant. En plus si je créer un nouveau projet Rails,
il me propose "generate rail application skeleton" mais même coché il
ne me créer rien... normal ?

Merci.

--
Thomas Bassetto
http://navigosaure.net
Fd608c2b5ba7896b449e26fcf18b70b4?d=identicon&s=25 Zambra (Guest)
on 2006-04-28 22:15
(Received via mailing list)
> Eclipse me sors qu'il me manque un plu-gin rubypeople....
>
> De toute façon, je cherche un tuto pour se servir de RadRails car
> c'est un peu déroutant. En plus si je créer un nouveau projet Rails,
> il me propose "generate rail application skeleton" mais même coché il
> ne me créer rien... normal ?

Inutile de lancer Eclipse si tu n'en as pas besoin. Radrails fonctionne
aussi en mode autonome (standalone)
Ensuite, il faut vérifier dans Window -> Preferences qu'il trouve bien
le répertoire ou Rails est installé
+ Rails -> rails installs
idem pour Ruby
0fd845e7824e980053d4f12c37d89652?d=identicon&s=25 Guillaume "Zifro" DESRAT (Guest)
on 2006-04-28 22:24
(Received via mailing list)
Bonsoir Thomas.

Il faut effectivement installer les Ruby Development Tools avant le
plugin RadRails.
Pour ma part, j'ai du installer les RDT en administrateur, puis le
plugin RadRails.

Tout fonctionne bien :)

--
Guillaume "Zifro" DESRAT
http://.../
-- Aah Jeez...I Wish You Could See This....Lights Coming Up.....I've
Never Seen A Painting That Captures The Beauty Of The Ocean.....I'm
Gonna Make You Rich, Bud Fox....Rich Enough You Can Afford A Girl Like
Darien....This Is Your Wake-Up Call, Pall....Go To Work.....DROP IT!!!
(3 Steps Ahead - Drop It)
05ab66b795a2cbdffc97d2b8209e3a6b?d=identicon&s=25 Thomas Bassetto (Guest)
on 2006-04-29 00:33
(Received via mailing list)
On 4/28/06, Zambra <zambra@free.fr> wrote:
> Inutile de lancer Eclipse si tu n'en as pas besoin. Radrails fonctionne
> aussi en mode autonome (standalone)
> Ensuite, il faut vérifier dans Window -> Preferences qu'il trouve bien
> le répertoire ou Rails est installé
> + Rails -> rails installs
> idem pour Ruby

Merci. Mais où est-ce fameux dossier d'installation de rails ? :p Je
l'ai installé via synaptic donc si quelqu'un comme moi utilise linux
je veux bien le savoir ;)

@Guillaume : Ok merci, j'essaierai.

--
Thomas Bassetto
http://navigosaure.net
0fd845e7824e980053d4f12c37d89652?d=identicon&s=25 Guillaume "Zifro" DESRAT (Guest)
on 2006-04-29 00:45
(Received via mailing list)
J'utilise OpenBSD, et Eclipse s'est installé (merci les packages !)
dans /usr/local/eclipse/.



--
Guillaume "Zifro" DESRAT
http://.../
-- Aah Jeez...I Wish You Could See This....Lights Coming Up.....I've
Never Seen A Painting That Captures The Beauty Of The Ocean.....I'm
Gonna Make You Rich, Bud Fox....Rich Enough You Can Afford A Girl Like
Darien....This Is Your Wake-Up Call, Pall....Go To Work.....DROP IT!!!
(3 Steps Ahead - Drop It)
B5e0bdc381418fa930a20c8dc767cca2?d=identicon&s=25 Lionel Porcheron (Guest)
on 2006-04-29 00:57
(Received via mailing list)
Bonsoir,
>
Comme cela a effectivement été dit sur la liste, il faut correctement
configurer tous les chemins d'accès (ruby, rails, etc.). Sur une Ubuntu
Dapper, le chemin est a priori /usr/share/rails (tu peux avoir la liste
des fichiers par un dpkg -l rails).

Cela étant, chez moi j'ai une installation d'eclipse qui n'est pas
packagée (mais rails, ruby le sont), et j'ai le même résultat que toi
:-(. Une rapide recherche ne m'a pas permis de trouver la cause du
problème...

Pour en revenir aux deux méthodes d'installation, la deuxième méthode
(via le mécanisme d'update d'eclipse) permet d'installer et de mettre à
jour "automatiquement". Cependant, ce mécanisme ne comprend pas de
résolution de dépendance (comme apt sur Ubuntu), il te faut donc
spécifier les deux update sites pour les deux packages.

Je te tiens au courant si je trouve la solution.

Lionel
05ab66b795a2cbdffc97d2b8209e3a6b?d=identicon&s=25 Thomas Bassetto (Guest)
on 2006-04-29 01:21
(Received via mailing list)
Merci pour le chemin, mais ça ne change rien pour moi :/

Pour rappel j'ai :
-rails et ruby installé via Synaptic donc par "paquet"
-d'un côté Eclipse installé par Synaptic aussi auquel j'ai installé
les plugins RadRails et RubyDevelopmentTools
-d'un autre côté RadRails standalone installé par dézippage de
l'archive téléchargée sur le site officiel

Avec aucun des deux, même en indiquant dans les Préférences le chemin
de l'installation de rails et de l'interpréteur ruby, je n'arrive à
faire marche la création d'un projet rails. Le projet créé est vide :|

--
Thomas Bassetto
http://navigosaure.net
This topic is locked and can not be replied to.