Forum: Rails France radrails config

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
27673041301931d2fa886f414191d52f?d=identicon&s=25 unknown (Guest)
on 2006-04-26 13:46
(Received via mailing list)
Bonjour,

J'utilise RoR depuis peu et tout fonctionne merveilleusement.

J'ai téléchargé RadRails qui fonctionne directement  sans installation
mais
me pose quelques problèmes:

1) l'interpréteur ruby ne fonctionne pas dans radrails  et j'obtiens ce
message

>
2) le serveur dans radrails ne veut pas se lancer

J'ai bien paramétré
Ruby Ri/rdoc
..\src\ruby-1.8.4\bin\rdoc
..\src\ruby-1.8.4\bin\ri
ainsi  que
Rails installs
..ruby\bin\

Il y a t-il un dossier spécifique où copier RadRails ?
Qu'est-ce qui cloche?
415a80eb88afdd18a5b776992ef9e12b?d=identicon&s=25 pmt (Guest)
on 2006-04-26 13:53
Bonjour,

> 1) l'interpréteur ruby ne fonctionne pas dans radrails  et j'obtiens ce
> message

As-tu installé rubypeople ? (http://updatesite.rubypeople.org/release:
il s'installe comme Radrails par Software Updates)

> 2) le serveur dans radrails ne veut pas se lancer

J'ai le même souci, donc pas de solution de ma part ;)

++
Pierre Marchet
9c406551e09ad8ebd7c3ce523514627c?d=identicon&s=25 Vincent Jauneau (Guest)
on 2006-04-26 14:08
(Received via mailing list)
>
> >
>
> Il y a t-il un dossier spécifique où copier RadRails ?
> Qu'est-ce qui cloche?
>


En faite dans les options de RadRails, il faut lui indiquer le chemin
vers
l'interpréteur Ruby.
Dans la dernière version de du plug-in RadRails, les options concernant
Ruby
ne sont pas sauvegardées chez moi, il faut donc lui indiquer le chemin à
chaque démarrage d'Eclipse. Je n'avais pas le problème sur la version
précédente.
64cefc5969da4ae702d86c9f26cb8733?d=identicon&s=25 philippe lachaise (Guest)
on 2006-04-26 14:29
(Received via mailing list)
Je n'ai pas la réponse mais un conseil pragmatique :

RadRails est génial comme IDE mais comme environnement d'execution (de
mon
expérience et d'autres autour de moi) il est pas blindé.

Solution : piloter l'application à la main, à partir d'une bonne vielle
boite DOS et faire un Refresh sur le projet (dans le treeview Radrails)
quand on a modifié l'arborescence (par ex. après un script/generate)

En conclusion (sous Windows en tout cas, ce qui semble être ton cas si
j'en
juge par les "\") :

   - Une boite DOS pour Webrick
   - Une boite DOS script/generate, scaffold et compagnie (j'utilise
fond
   de couleur différente pour m'y retrouver)
   - Click-droit + Refresh dans RadRails pour syncroniser

Solution bas de gamme mais zero tracas :)
69c6b1bd3e92fd07862b81621916a3fa?d=identicon&s=25 Julien Carnelos (Guest)
on 2006-04-26 14:36
(Received via mailing list)
Pour le refresh, on peut demander directement à eclipse dans General ->
Workspace -> "Refresh automatically".

Julien
30d2fbcfa70a6ed4fd0bceda145f3758?d=identicon&s=25 Benjamin Francisoud (Guest)
on 2006-04-26 16:42
(Received via mailing list)
philippe lachaise wrote:

> Je n'ai pas la réponse mais un conseil pragmatique :
>
> RadRails est génial comme IDE mais comme environnement d'execution (de
> mon expérience et d'autres autour de moi) il est pas blindé.

Sous Windows XP, je n'ai plus de problème avec les dernières versions de
l'update-site de radrails.
Le serveur démarre correctement...
Les generateurs (scaffold...) sont ok aussi.

Par contre c'est vrai que l'interpréteur ruby sélectionné disparaît à
chaque fois que j'éteind eclipse... c'est désagréable.
Je pense qu'ils vont corriger ça rapidement... idéalement il faudrait
vérifier s'il y a un bug ouvert et en ouvrir le si ce n'est pas le cas...

--
Benjamin Francisoud
http://rubyscube.blogspot.com
Fd608c2b5ba7896b449e26fcf18b70b4?d=identicon&s=25 Zambra (Guest)
on 2006-04-26 17:20
(Received via mailing list)
> Par contre c'est vrai que l'interpréteur ruby sélectionné disparaît à
> chaque fois que j'éteind eclipse... c'est désagréable.
> Je pense qu'ils vont corriger ça rapidement... idéalement il faudrait
> vérifier s'il y a un bug ouvert et en ouvrir le si ce n'est pas le cas...

J'ai la 0.6.2 en standalone et je n'ai pas ce problème
0fd845e7824e980053d4f12c37d89652?d=identicon&s=25 Guillaume "Zifro" DESRAT (Guest)
on 2006-04-26 21:14
(Received via mailing list)
Bonsoir,

j'utilise Eclipse 3.1.0 et les Ruby Development Tools
0.7.0.601192300PRD, sous OpenBSD 3.8 (Eclipse installé à partir des
packages).
J'utilise RadRails en tant que plugin à Eclipse et non pas en version
"standalone".

J'ai rencontré un problème avec la version 0.6.2, qui m'affichait une
erreur et ne me permettait pas d'éditer un fichier .rhtml.

Je suis revenu en version 0.6.1 (merci Eclipse !) et tout fonctionne
bien.


--
Guillaume "Zifro" DESRAT
http://.../
-- Aah Jeez...I Wish You Could See This....Lights Coming Up.....I've
Never Seen A Painting That Captures The Beauty Of The Ocean.....I'm
Gonna Make You Rich, Bud Fox....Rich Enough You Can Afford A Girl Like
Darien....This Is Your Wake-Up Call, Pall....Go To Work.....DROP IT!!!
(3 Steps Ahead - Drop It)
64cefc5969da4ae702d86c9f26cb8733?d=identicon&s=25 philippe lachaise (Guest)
on 2006-04-26 22:25
(Received via mailing list)
Ca m'est arrivé de ne plus pouvoir éditer tel ou tel type de source
d'une
version à l'autre de RadRails.

J'ai l'impression qu'Eclipse/RadRails ne récupère pas toujours bien le
Workspace entre certaines versions et que ça a des conséquences
bizarres.

En réimportant mes projets dans un nouveau workspace j'arrivais à
repartir
normalement
Fd608c2b5ba7896b449e26fcf18b70b4?d=identicon&s=25 Zambra (Guest)
on 2006-04-26 23:31
(Received via mailing list)
> J'ai rencontré un problème avec la version 0.6.2, qui m'affichait une
> erreur et ne me permettait pas d'éditer un fichier .rhtml.

C'est un bug connu d'ERB si j'ai bien compris, regarde si ce n'est pas
celui là :
http://dev.radrails.org/trac/ticket/780

Even pasting this into the RHTML editor gives me an "argument not valid"
error, so it's gotta be something in the syntax highlighting code.

RHTML, meet your doom:
<death to="the <%= "RHTML editor" %>">

Other flavors of doom:
<death to ="the <%= "RHTML editor" %>">
<death to="the <%= "RHTML editor" %>" >
< death to="the <%= "RHTML editor" %>">
< death to="the <%= "RHTML editor" %>" >

But these variants do not cause the RHTML editor to make the bad noise:

<death to="the <% = "RHTML editor" %>">
<death to "the <%= "RHTML editor" %>">
death to="the <%= "RHTML editor" %>"
<death to = "the <%= "RHTML editor" %>">
<death to= "the <%= "RHTML editor" %>">
<death to=" the <%= "RHTML editor" %>">
<death to="the <% "RHTML editor" %>">
<death to="<%= "\"the RHTML editor\"" %>>
27673041301931d2fa886f414191d52f?d=identicon&s=25 kernel-panic (Guest)
on 2006-05-01 11:10
tout à fait, il faut supprimer le chemin par defaut et indique
l'emplacement de l'executable.

Ruby> Installed Interpreters
ruby.exe


Vincent Jauneau wrote:
>>
>> >
>>
>> Il y a t-il un dossier spécifique où copier RadRails ?
>> Qu'est-ce qui cloche?
>>
>
>
> En faite dans les options de RadRails, il faut lui indiquer le chemin
> vers
> l'interpréteur Ruby.
> Dans la dernière version de du plug-in RadRails, les options concernant
> Ruby
> ne sont pas sauvegardées chez moi, il faut donc lui indiquer le chemin à
> chaque démarrage d'Eclipse. Je n'avais pas le problème sur la version
> précédente.
This topic is locked and can not be replied to.