Forum: Ruby on Rails Capistrano - SSH Port

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ff82af3238a57fbd1212832ec1a19f28?d=identicon&s=25 Dylan Stamat (Guest)
on 2006-04-22 05:46
(Received via mailing list)
I've been deploying with Capistrano for a while now, and have had no
problems... until now.

When I try and do a "cap deploy", cap tries to connect to my remote
server
via SSH on port 22... even though in my deploy.rb, I've had the
following
set:
ssh options[:port] = 8081

I did a "sudo gem update --remote capistrano", and I'm up to speed on
the
latest release, so am utterly confused as to why it's not picking up
this
option from the config.

Any ideas ?
992fe8c19bbbc27f2b562a9f96efc03d?d=identicon&s=25 Jamis Buck (Guest)
on 2006-07-06 05:15
(Received via mailing list)
On Apr 21, 2006, at 9:44 PM, Dylan Stamat wrote:

> I've been deploying with Capistrano for a while now, and have had
> no problems... until now.
>
> When I try and do a "cap deploy", cap tries to connect to my remote
> server via SSH on port 22... even though in my deploy.rb, I've had
> the following set:
> ssh options[:port] = 8081

Is that a space or underscore between "ssh" and "options"? It should be:

   ssh_options[:port] = 8081

I just tried it locally and it seems to be honoring the port here.

- Jamis
This topic is locked and can not be replied to.