Forum: Ruby on Rails Mail notifications to self Net::SMTPAuthenticationError

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D46676ea3135a46b4e65333c45571b5c?d=identicon&s=25 bradford li (Guest)
on 2014-11-18 21:23
(Received via mailing list)
I am trying to set up a mailer to send myself notification methods. I am
currently trying to get the mailer to send myself a simple message when
I
go to the URL `localhost:3000/send_mail`

I am currently getting this error:

    Net::SMTPAuthenticationError in HomeController#send_mail
    534-5.7.9 Application-specific password required

development.rb:

      config.action_mailer.raise_delivery_errors = true
      host = 'localhost:3000'
      config.action_mailer.default_url_options = { host: host }
      config.action_mailer.delivery_method = :smtp
      config.action_mailer.smtp_settings = {
        address:              'smtp.gmail.com',
        port:                 587,
        domain:               'gmail.com',
        user_name:            'myemail@gmail.com',
        password:             'mypwd',
        authentication:       'plain',
        enable_starttls_auto: true  }

routes:

   match '/send_mail', to: "home#send_mail", via: "get"

home controller:

    class HomeController < ApplicationController
      def index
      end

      def send_mail
      ActionMailer::Base.mail(:from => "me@example.com", :to =>
"myemail@gmail.com", :subject => "Contact request", :body =>
"test").deliver_now
        render nothing: true
      end
    end
230650ca4eae6beb5d52db56bd1c8e81?d=identicon&s=25 wdperson (Guest)
on 2014-11-18 21:34
(Received via mailing list)
Hello,

The reason you are getting that error is because more than likely you
have
set up 2 factor authentication with Google/Gmail.  So it is saying you
need
to include a application specific password.  In other words don't use
the
usual login password, create an application specific password on
Google/Gmail and then use that in your smtp settings.  Hope this helps.

Mike Riley
Ef3aa7f7e577ea8cd620462724ddf73b?d=identicon&s=25 Rob Biedenharn (Guest)
on 2014-11-18 21:35
(Received via mailing list)
D46676ea3135a46b4e65333c45571b5c?d=identicon&s=25 bradford li (Guest)
on 2014-11-18 21:43
(Received via mailing list)
Thank you!! worked like a charm!
D46676ea3135a46b4e65333c45571b5c?d=identicon&s=25 bradford li (Guest)
on 2014-11-18 21:43
(Received via mailing list)
thank you!!! worked perfectly!!
This topic is locked and can not be replied to.