Forum: Ruby on Rails login_engine database migration broken?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
6ec1e89eef5ce09fbfa56be5b6dd17b5?d=identicon&s=25 Adam Bloom (admanb)
on 2006-04-15 06:03
I'm trying to install the login_engine. I installed the engine system
and the login_engine, and now I'm trying to migrate the database schema,
as detailed here: http://api.rails-engines.org/login_engine/.

The commands I've tried are:

rake engine_migrate ENGINE=login which fails with "Don't know how to
build task 'engine_migrate'."

and:

rake import_login_engine_schema ENGINE=login which fails with "no such
file to load --
/Users/admanb/Documents/h4x/Ruby/anime/config/../vendor/plugins/login_engine/db/schema.rb"

and there is, infact, no such file. There's only one named
"001_initial_schema.rb" in login_engine/db/migrate.

Will it work find if I just add the table to my sql database? Thanks,

Adam
48ae1944e6a82dffa18694663e72c931?d=identicon&s=25 Pedro Visintin (peterpunk)
on 2006-04-15 06:20
Adam Bloom wrote:
> I'm trying to install the login_engine. I installed the engine system
> and the login_engine, and now I'm trying to migrate the database schema,
> as detailed here: http://api.rails-engines.org/login_engine/.
>
> The commands I've tried are:
>
> rake engine_migrate ENGINE=login which fails with "Don't know how to
> build task 'engine_migrate'."
>
> and:
>
> rake import_login_engine_schema ENGINE=login which fails with "no such
> file to load --
> 
/Users/admanb/Documents/h4x/Ruby/anime/config/../vendor/plugins/login_engine/db/schema.rb"
>
> and there is, infact, no such file. There's only one named
> "001_initial_schema.rb" in login_engine/db/migrate.
>
> Will it work find if I just add the table to my sql database? Thanks,
>
> Adam

Hi Adam:

Im using login and user engines with rails 1.1.2

My question may be obvious but...
Have you installed plugin engines?

Which rails version do you have?

P

http://wiki.onrails.com.ar
6ec1e89eef5ce09fbfa56be5b6dd17b5?d=identicon&s=25 Adam Bloom (admanb)
on 2006-04-15 07:19
Rails 1.1.2, and yeah I have.

I got it working though. I took the file "001_initial_schema.rb" moved
it to root/db/migrate and did a rake migrate. That worked.

I think it's just a problem with the documentation.

Thanks,

-Adam
E85bf1e379af88284601269326014248?d=identicon&s=25 Jason Tahaney (Guest)
on 2007-04-05 02:33
Hi, I'm experiencing a similar issue however I don't think it's a
problem with the documentation since after you install the Engines
plugin, my understanding is that there should be added rake tasks, like
db:migrate:engines and a few others.

I followed the instructions per the Engines plugin installation note and
the install reported that it had successfully installed, yet when i do a
rake db:migrate:engines ENGINE=login I get the same rake task not found
type error and sure enough when I do a rake -T there is no
db:migration:engines task.

When I run script/plugins list --remote it does show that both the
engines and login_engine are both installed.

When rake executes where and how does it lookup available rake tasks?
Also do I need to add anything to the environments.rb file to help rails
find the plugin directory?

Thanks in advance,

Jason


Adam Bloom wrote:
> Rails 1.1.2, and yeah I have.
>
> I got it working though. I took the file "001_initial_schema.rb" moved
> it to root/db/migrate and did a rake migrate. That worked.
>
> I think it's just a problem with the documentation.
>
> Thanks,
>
> -Adam
This topic is locked and can not be replied to.