Forum: Ruby on Rails Two versions of Rails on one PC

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D63d38971d813a9c7cf06da46832b8f8?d=identicon&s=25 r00by n00by (Guest)
on 2006-04-11 14:14
I want to have Rails 1.1 + Rails 1.0 on the same PC and be able to load
my script  with a different version each time. Is it possible?
Cd8c9864d88bcafc164d8fdb820cc451?d=identicon&s=25 Chris Richards (chris)
on 2006-04-11 14:18
Fully explain yourself if you want decent help
A2c85dc5ee81b12e3cc0a6522e8d079d?d=identicon&s=25 Chris Hall (Guest)
on 2006-04-11 14:40
(Received via mailing list)
well, you could do a few things...here is just my opinion.

install rails systemwide as 1.1 (actually, 1.1.2 is now available).

then for the apps you want to run as 1.0, run:

rake rails:freeze:edge TAG=rel_1-0-0

inside your app directory.  this will install rails local to the app
(specifically, it installs rails to the vendor directory in your app)

if you want to go back to the system install of rails:

rake rails_unfreeze (normally this would be rake rails:unfreeze but that
is
a 1.1+ thing apparently)

for more options, run rake -T in your app directory

hope this helps.
2b891e820c238ded365d035771603f21?d=identicon&s=25 Bill Walton (Guest)
on 2006-04-11 15:20
(Received via mailing list)
You can do this quite easily with Instant Rails, as each is a
stand-alone
'package'.  Can't have both running at the same time, though.

hth,
Bill
----- Original Message -----
From: "r00by n00by" <a52p8cwbpjz91m7@jetable.net>
To: <rails@lists.rubyonrails.org>
Sent: 2006-04-11 7:14 AM
Subject: [Rails] Two versions of Rails on one PC
D63d38971d813a9c7cf06da46832b8f8?d=identicon&s=25 r00by n00by (Guest)
on 2006-04-11 20:23
Instant Rails looks like a good idea if I hadn't already have Rails and
MySql installed.


I installed Rails 1.1.2 and tried running my app. Of course there were
some errors as expected. Then I ran "rake rails:freeze:edge
TAG=rel_1-0-0" and it seems that I got the old version back now. But
there is one strange thing - while running a test under 1.1.2 I got this
warning:

  don't put space before argument parentheses

This was the first time I got it. After returning to 1.0 I expected this
warning to be gone, but it's still there. Does it mean that the old
version was not restored completely?
This topic is locked and can not be replied to.