Forum: Ruby on Rails lighttpd fcgi and rails banchmarks

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Def5baf8afb713e4d7303e795d66d973?d=identicon&s=25 news.gmane,org (Guest)
on 2006-04-08 22:56
(Received via mailing list)
I have been testing various web development solutions on an unloaded
Mandrake Opteron 150/1Gb box.

I am a little confused about my results on lighttpd with apachebench.
Results are requests per second, all test scripts simply output 'Hello,
World' in plain text.

Static HTML 11488
FastCGI Perl   6350
C CGI             2015
Perl CGI            597
Ruby CGI          259
RoR FastCGI     180 <-- ??
RoR CGI             31 <-- !!

Does this look right, or should I be looking at problems with my config?
I expected Rails to have greater overhead since it is a full framework,
but
is this the best performance I can expect?
Ad7805c9fcc1f13efc6ed11251a6c4d2?d=identicon&s=25 Alex Young (Guest)
on 2006-04-10 11:30
(Received via mailing list)
news.gmane,org wrote:
> Perl CGI            597
> Ruby CGI          259
> RoR FastCGI     180 <-- ??
> RoR CGI             31 <-- !!
>
> Does this look right, or should I be looking at problems with my config?
> I expected Rails to have greater overhead since it is a full framework, but
> is this the best performance I can expect?
Were those figures taken with the app in development or production mode?
This topic is locked and can not be replied to.