Forum: Radiant CMS Uninitialized constant Aftimagr (NameError)

4b0b74182a3ec93bc6687f6e104e3bb4?d=identicon&s=25 Akeel Qureshi (akeel_q)
on 2010-12-08 08:00
Hello All

I am getting this error, any one resolved this..... it's urgent


ruby script/server --debugger
=> Booting WEBrick...
=> Debugger enabled
config.gem: Unpacked gem rspec-rails-1.1.11 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem rubyist-aasm-2.0.2 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem capistrano-ext-1.2.1 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem ruby-openid-2.1.2 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem rspec-1.1.11 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem mislav-will_paginate-2.3.6 in vendor/gems has
no specification file. Run 'rake gems:refresh_specs' to fix this.
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:445:in
`load_missing_constant': uninitialized constant Aftimagr (NameError)
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:77:in
`const_missing'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:89:in
`const_missing'
  from
/home/nimish/Akeel/Project/COOP/rails/config/initializers/aftimagr.rb:1
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:142:in
`load_without_new_constant_marking'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:142:in
`load'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:142:in
`load'
  from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:550:in
`load_application_initializers'
  from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:549:in
`each'
  from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:549:in
`load_application_initializers'
  from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:167:in
`process'
  from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in
`send'
  from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in
`run'
  from /home/nimish/Akeel/Project/COOP/rails/config/environment.rb:13
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/commands/servers/webrick.rb:59
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
  from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/commands/server.rb:49
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from script/server:3


Thanks
Akeel Qureshi
58ce6437f17a1ca96049500cf66ece6f?d=identicon&s=25 swartz (Guest)
on 2010-12-08 08:52
(Received via mailing list)
Have you installed all dependencies?

From quick glance, it appears like you're missing this:

https://github.com/haikuwebdev/aftimagr

--
Swartz
This topic is locked and can not be replied to.