Forum: Ruby on Rails rails Test problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
901bd2942185e3998fdfd5e613042aab?d=identicon&s=25 Kevin Schmeichel (Guest)
on 2006-04-05 00:16
(Received via mailing list)
Hi-

  I'm trying to install the latest version (1.1) of Ruby on Rails on an
Ubuntu
5.10 (Breezy Badger) system.  I compiled ruby, installed gems, and gem
installed rails, no problem.

  However, when I try and set up a test app a get the following error:

~> rails Test
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:84:in
`const_missing': undefined method `demodulize' for
"ActiveRecordError":String
(NoMethodError)

from
/usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/validations.rb:9

from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'

from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:136:in
`require'

from
/usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record.rb:39

from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:182:in
`activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:181:in
`activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:167:in
`activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:166:in
`activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
`require_gem_with_options'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:31:in
`require_gem'
        from /usr/local/bin/rails:17

  Any ideas?

Thanks,
Kevin
This topic is locked and can not be replied to.