Forum: Ruby on Rails Oracle Problem. Maybe driver

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cd8c9864d88bcafc164d8fdb820cc451?d=identicon&s=25 Chris (Guest)
on 2006-04-04 17:03
EVerything runs ok on my local machine but when i copy my app to our
solaris server everything is fine until i try updating/inserting
something into the DB.

This is the error message :

wrong number of arguments (1 for 0)

RAILS_ROOT: config/..
Application Trace | Framework Trace | Full Trace

/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/connection_adapters/oracle_adapter.rb:53:in
`attributes_with_quotes_pre_oracle'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/connection_adapters/oracle_adapter.rb:53:in
`attributes_with_quotes'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/base.rb:1719:in
`update_without_lock'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/locking.rb:33:in
`update_without_callbacks'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/callbacks.rb:274:in
`update_without_timestamps'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/timestamp.rb:39:in
`update'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/base.rb:1712:in
`create_or_update_without_callbacks'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/callbacks.rb:249:in
`create_or_update'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/base.rb:1388:in
`save_without_validation'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/validations.rb:724:in
`save_without_transactions'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/transactions.rb:126:in
`save'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/connection_adapters/abstract/database_statements.rb:51:in
`transaction'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/transactions.rb:91:in
`transaction'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/transactions.rb:118:in
`transaction'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/transactions.rb:126:in
`save'
/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/associations/association_proxy.rb:110:in
`method_missing'
#{RAILS_ROOT}/app/models/contact.rb:83:in
`make_active_contact_for_employee'
#{RAILS_ROOT}/app/models/contact.rb:80:in
`make_active_contact_for_employee'
#{RAILS_ROOT}/app/controllers/user_preferences_controller.rb:17:in
`change_active_contact'
/opt/tools/bin/mongrel_rails:18


As i do not get this problem on my local machine i am tempted to assume
that it is something to do with the oracle driver, not really sure.
Does anyone have any ideas?

Thanks, any help is appreciated,

Chris
Cd8c9864d88bcafc164d8fdb820cc451?d=identicon&s=25 Chris (Guest)
on 2006-04-04 17:56
Has anyone else had this oracle problem?
6a657bbaaa704aa1fc7dfa6d680c06fc?d=identicon&s=25 Phillip Novess (Guest)
on 2006-04-04 18:03
(Received via mailing list)
What problem?


On Apr 4, 2006, at 9:56 AM, Chris wrote:

Has anyone else had this oracle problem?

--
Posted via http://www.ruby-forum.com/.
_______________________________________________
Rails mailing list
Rails@lists.rubyonrails.org
http://lists.rubyonrails.org/mailman/listinfo/rails
5d15c6821f3c3054c04b85471824ba7c?d=identicon&s=25 Lori Olson (Guest)
on 2006-04-04 19:11
(Received via mailing list)
On Tuesday, April 04, 2006, at 5:03 PM, Chris wrote:
>
>/opt/tools/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/
>active_record/connection_adapters/oracle_adapter.rb:53:in
>`attributes_with_quotes_pre_oracle'

>As i do not get this problem on my local machine i am tempted to assume
>that it is something to do with the oracle driver, not really sure.
>Does anyone have any ideas?
>
>Thanks, any help is appreciated,
>
>Chris
>

It's a regression introduced in Rails 1.1.  There is a patch.  It will
be fixed in Rails 1.1.1.

http://dev.rubyonrails.org/ticket/4457

--
Lori Olson
http://blog.dragonsharp.com
E75cda3e915fa209386fae3de962cb6a?d=identicon&s=25 Michael Schoen (Guest)
on 2006-04-05 02:20
(Received via mailing list)
There's a bug in Rails 1.1, fixed in edge rails.
5f699f59b58693ce313995caf4330486?d=identicon&s=25 Ben Anderson (Guest)
on 2006-04-06 16:57
(Received via mailing list)
I'm having this problem, too.  I'm not even using oracle, but rather
mysql.
E75cda3e915fa209386fae3de962cb6a?d=identicon&s=25 Michael Schoen (Guest)
on 2006-04-07 06:21
(Received via mailing list)
Ben Anderson wrote:
> I'm having this problem, too.  I'm not even using oracle, but rather mysql.
>

This problem is resolved in Rails 1.1.1
This topic is locked and can not be replied to.