Forum: Ruby on Rails Cannot upgrade rails to 1.1, only 1.0. Nubee. Please help

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cd8c9864d88bcafc164d8fdb820cc451?d=identicon&s=25 Chris (Guest)
on 2006-04-04 11:19
I've used putty to SSH in to our solaris system as root:
Here is what happens when i try to install rails:

# gem install rails -include-dependencies -p http://saiproxy:3128
Attempting local installation of 'rails'
Local gem file not found: rails*.gem
Attempting remote installation of 'rails'
Successfully installed rails-1.0.0

So my question is why won't it go to rails1.1?? I need it for the rails
1.1 app i have been developing on my local machine.

Any help would be appreciated,

Thanks,
Chris
E28c35323f624b8b9ed8712e25105454?d=identicon&s=25 Ray Baxter (Guest)
on 2006-04-04 12:54
(Received via mailing list)
Chris wrote:
> 1.1 app i have been developing on my local machine.
Assuming you've tried without the proxy and with the version:

# gem install rails --version >= 1.1 --include-dependencies

or know for certain that the proxy is necessary for you, I'd download
the gems and install them locally.

Here's at least a start on that:

Down load the rails gem from http://tinyurl.com/hn6dh and then

# gem install rails-1.1.0.gem

The problem with this is that you'll have to also download the
dependencies.

# gem dependency rails

Will give you a list of what you need, although if it does, I don't know
why you wouldn't be getting the correct version. So here is the list I
see:

Gem rails-1.1.0
   Requires
     rake (>= 0.7.0)
     activesupport (= 1.3.0)
     activerecord (= 1.14.0)
     actionpack (= 1.12.0)
     actionmailer (= 1.2.0)
     actionwebservice (= 1.1.0)



--

Ray
Cd8c9864d88bcafc164d8fdb820cc451?d=identicon&s=25 Chris (Guest)
on 2006-04-04 15:47
Thanks for that Ray,

do you know where i can download the dependent gems from?
I need it to install rails-1.1.0.gem


Thanks,
Chris
E28c35323f624b8b9ed8712e25105454?d=identicon&s=25 Ray Baxter (Guest)
on 2006-04-04 17:54
(Received via mailing list)
Chris wrote:

> do you know where i can download the dependent gems from?
> I need it to install rails-1.1.0.gem

Everything is at rubyforge.org


--

Ray
435630373f6ee0fd7d1e0142d1ccb625?d=identicon&s=25 Peter Gibbons (Guest)
on 2006-04-04 17:56
Chris wrote:
> Thanks for that Ray,
>
> do you know where i can download the dependent gems from?
> I need it to install rails-1.1.0.gem
>
>
> Thanks,
> Chris

If you use '--include-dependencies', the dependent gems should
automatically get downloaded and installed for you.
This topic is locked and can not be replied to.