Forum: Ruby ruby and xemacs syntax highlighting

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
58282afa4411f1eba029fa3720f02c98?d=identicon&s=25 Pieter Breed (Guest)
on 2006-04-03 08:49
(Received via mailing list)
Hi All,

I am trying to get syntax highlighting to work with xemacs. I have the
latest xemacs, I downloaded and installed the ruby package, it does
detect ruby mode (once I do the font-lock thing), but

Only my constanc strings are highlighted. None of the keywords or
variable names are highlighted. Can you please help me with this?

Regards,
Pieter
455ac2a64d06dc8461f4d258d7f7e980?d=identicon&s=25 Michael Trier (Guest)
on 2006-04-03 15:12
(Received via mailing list)
Here's my relevant section. By the way this gives you the Ink
(whatever they call it look)

;; ruby-mode
(autoload 'ruby-mode "ruby-mode" "Load ruby-mode")
(add-to-list 'auto-mode-alist '("\\.rb$" . ruby-mode))

;; uncomment the next line if you want syntax highlighting
(add-hook 'ruby-mode-hook 'turn-on-font-lock)

(cond ((fboundp 'global-font-lock-mode)
       ;; Customize face attributes
       (setq font-lock-face-attributes
             ;; Symbol-for-Face Foreground Background Bold Italic
Underline
             '((font-lock-comment-face       "Purple")
               (font-lock-string-face        "green")
               (font-lock-keyword-face       "orange red")
               (font-lock-function-name-face "orange1")
               (font-lock-variable-name-face "white")
               (font-lock-type-face          "white" "black" "false"
"false" "true")
               (font-lock-reference-face     "Purple")
               ))
       ;; Load the font-lock package.
       (require 'font-lock)
       ;; Maximum colors
       (setq font-lock-maximum-decoration t)
       ;; Turn on font-lock in all modes that support it
       (global-font-lock-mode t)))
This topic is locked and can not be replied to.