Forum: Ruby on Rails Syncpeople Plugin Scope Never Active

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
24e30ea2f4bfda89a9a915dd18247d05?d=identicon&s=25 Jeremy Huffman (Guest)
on 2006-04-01 17:14
(Received via mailing list)
I installed the Syncpeople textmate bundle (
http://syncpeople.com/downloads/syncpeople_on_rails_features ) and the
commands all work from the menu, but the short-cuts never work for any
of the snippets or commands ever work, because the scopes are not
being selected properly. If I change the scope to just "source.ruby"
it will work fine. But I cannot see why their scope selectors do not
work in my file.

Their scopes are pretty simple too, here is an example for the
controller:

		{	name = 'meta.rails.controller';
			comment = 'Uses lookahead to match classes with the Controller
suffix; includes ''source.ruby'' to avoid infinite recursion';
			begin =
'(^\s*)(?=class\s+(([.a-zA-Z0-9_:]+Controller\b(\s*<\s*[.a-zA-Z0-9_:]+)?)|(<<\s*[.a-zA-Z0-9_:]+)))(?!.+\bend\b)';
			end = '^\1(?=end)\b';
			patterns = (
				{ include = 'source.ruby'; },
				{ include = '$self'; } );
		}


--
Jeremy Huffman
http://www.jeremyhuffman.com
59de94a56fd2c198f33d9515d1c05961?d=identicon&s=25 Tom Mornini (Guest)
on 2006-04-01 21:25
(Received via mailing list)
I have this same problem.

--
-- Tom Mornini
24e30ea2f4bfda89a9a915dd18247d05?d=identicon&s=25 Jeremy Huffman (Guest)
on 2006-04-02 01:37
(Received via mailing list)
Ok, I had a "duh" moment and realized my lang at the bottom was set to
Ruby not Ruby on Rails. This fixed the snippets and so forth that look
for source.ruby.rails but still no luck with the meta scopes
(controllers, views etc for the goto other file commands)

On 4/1/06, Tom Mornini <tmornini@infomania.com> wrote:
> > of the snippets or commands ever work, because the scopes are not
> >                       begin = '(^\s*)(?=class\s+(([.a-zA-Z0-9_:]+Controller\b(\s*<\s*
> > http://www.jeremyhuffman.com
> > _______________________________________________
> > Rails mailing list
> > Rails@lists.rubyonrails.org
> > http://lists.rubyonrails.org/mailman/listinfo/rails
>
> _______________________________________________
> Rails mailing list
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails
>


--
Jeremy Huffman
http://www.jeremyhuffman.com
24e30ea2f4bfda89a9a915dd18247d05?d=identicon&s=25 Jeremy Huffman (Guest)
on 2006-04-02 03:51
(Received via mailing list)
I fixed it, the "go to ... " commands all recognize scopes properly I
just needed to re-enter the short-cut commands in the bundle window.
They were showing the right command but with a little circle character
behind them, not sure what that meant but obviously something like
they were disabled for some reason.

On 4/1/06, Jeremy Huffman <jeremy@jeremyhuffman.com> wrote:
> >
> > > Their scopes are pretty simple too, here is an example for the
> > >                               { include = '$self'; } );
> >
>
--
Jeremy Huffman
http://www.jeremyhuffman.com
This topic is locked and can not be replied to.