Forum: Ruby on Rails Install rubygems error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
B39dfb8d49b0938c4c742b449c3d31b8?d=identicon&s=25 Stuart Batty (Guest)
on 2006-03-31 23:01
(Received via mailing list)
I made the mistake of trying to upgrade to 1.8.4 from 1.8.2 and had
intended
to upgrade to rails 1.1. I have now completely borked my ruby gems
installation. After installing ruby I get the following error when
trying to
execute gem:
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__': no such file to load -- zlib (LoadError)
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:9
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:1
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:61:in
`manage_gems'
        from /usr/local/bin/gem:4
So I decided to re-install rubygems. When trying to run setup.rb I get:
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__': no such file to load -- zlib (LoadError)
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:9
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:1
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:61:in
`manage_gems'
        from /home/stuart/rubygems-0.8.11/./post-install.rb:64:in
`install_sources'
        from /home/stuart/rubygems-0.8.11/./post-install.rb:75:in
`try_run_hook'        from setup.rb:577:in `run_hook'
        from setup.rb:1315:in `exec_task_traverse'
        from setup.rb:1168:in `exec_install'
        from setup.rb:887:in `exec_install'
        from setup.rb:705:in `invoke'
        from setup.rb:674:in `invoke'
        from setup.rb:1352
The "/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__': no such file to load -- zlib (LoadError)" entry seems to be
trying to "require__ path" at line 21 of custom_require.rb line 21.

Can anyone help me get my rails back? I swear I'll never try to upgrade
again..:-)
--
View this message in context:
http://www.nabble.com/Install-rubygems-error-t1376...
Sent from the RubyOnRails Users forum at Nabble.com.
7ed3175d60e44aa7cb891973223e3998?d=identicon&s=25 Chad Fowler (Guest)
on 2006-04-01 02:40
(Received via mailing list)
On 3/31/06, Stuart Batty <stuart.batty@gmail.com> wrote:
>
> I made the mistake of trying to upgrade to 1.8.4 from 1.8.2 and had intended
> to upgrade to rails 1.1. I have now completely borked my ruby gems
> installation. After installing ruby I get the following error when trying to
> execute gem:
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
> `require__': no such file to load -- zlib (LoadError)
> Can anyone help me get my rails back? I swear I'll never try to upgrade
> again..:-)

You don't appear to have ruby's zlib module installed.  You can find
out by doing:

$ irb
rirb(main):001:0> require 'zlib'
=> true

You will probably see an error instead of "true".  Did you install
Ruby from source?

--
Chad Fowler
http://chadfowler.com
http://pragmaticprogrammer.com/titles/fr_rr/ (Rails Recipes - In Beta!)
http://pragmaticprogrammer.com/titles/mjwti/ (My Job Went to India,
and All I Got Was This Lousy Book)
http://rubycentral.org
http://rubygarden.org
http://rubygems.rubyforge.org (over one million gems served!)
C1e5a9e9344b6d31b9df7303e6dc378a?d=identicon&s=25 Craig White (Guest)
on 2006-04-01 02:52
(Received via mailing list)
On Fri, 2006-03-31 at 17:39 -0700, Chad Fowler wrote:
>
> You don't appear to have ruby's zlib module installed.  You can find
> out by doing:
>
> $ irb
> rirb(main):001:0> require 'zlib'
> => true
>
> You will probably see an error instead of "true".  Did you install
> Ruby from source?
----
Chad - your presence on the list usually signifies another update to
Recipes...is that forthcoming RSN?

I haven't updated my pdf from the last update and I was kind of waiting
for the next update because I am rapidly approaching the moment where I
will have time and my understanding of rails has improved to the point
that I might be able to better grok the things in your book.

Craig
804bfba7969f642f671ba1316c378af1?d=identicon&s=25 Scott Mathieson (Guest)
on 2006-04-01 03:23
(Received via mailing list)
not sure what OS you're on but make sure you have installed the
zlib-devel in
addition to zlib package if it's appropriate for you - i had this exact
issue
a while back

may have to reinstall gems too, i can't remember sorry
B39dfb8d49b0938c4c742b449c3d31b8?d=identicon&s=25 Stuart Batty (Guest)
on 2006-04-01 07:13
(Received via mailing list)
Chad,
Thank you for the information. Yes, I did install ruby from source
(v1.8.4)
on Ubuntu 5.10. You are correct about zlib. I got the following message:
stuart@kubuntu:~$ irb
irb(main):001:0> require 'zlib'
LoadError: no such file to load -- zlib
        from (irb):1:in `require'
        from (irb):1
irb(main):002:0> exit

Zlib was installed at one time but it is now either among the absentees
or
somehow munged beyond repair. I'll reinstall zlib and see where that
gets
me.

I can't believe I actually got help from Chad Fowler....how cool is
that?

--
View this message in context:
http://www.nabble.com/Install-rubygems-error-t1376...
Sent from the RubyOnRails Users forum at Nabble.com.
2c51fec8183a5d21c4e11b430beabb47?d=identicon&s=25 Patrick Hurley (Guest)
on 2006-04-01 07:26
(Received via mailing list)
On 4/1/06, Stuart Batty <stuart.batty@gmail.com> wrote:
>
> _______________________________________________
> Rails mailing list
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails
>


FYI If you were missing zlib, you are likely missing readline dev
stuff as well -- this will be an issue if you like to use console/irb.
I went through similar issues on ubuntu after upgrading ruby.

pth
B39dfb8d49b0938c4c742b449c3d31b8?d=identicon&s=25 Stuart Batty (Guest)
on 2006-04-01 07:53
(Received via mailing list)
Thanks Scott and Patrick as well. I re-installed zlib and zlib-devel and
re-compiled ruby and I was able to setup rubygems. Thanks again.

Patrick, can you explain a little more about the readline dev stuff?
What
packages do I need for Ubuntu? Should I install the readline dev stuff
and
then re-compile ruby again so it will "pick up" the readline dev libs?
--
View this message in context:
http://www.nabble.com/Install-rubygems-error-t1376...
Sent from the RubyOnRails Users forum at Nabble.com.
This topic is locked and can not be replied to.