Forum: Typo How to lock Typo to Rails 1.0?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ae577905a543a759b11ce883ffd00ef6?d=identicon&s=25 Sean Mountcastle (Guest)
on 2006-03-29 05:03
(Received via mailing list)
My hosting provider has upgraded to Rails 1.1 without any warning and
it looks like all of the hosted Typo installs are down :(

I tried adding the following to config/environment.rb at the top of
the file, but by that point the Rails 1.1 libraries have already been
loaded (not sure how as the calling script is dispatch.fcgi):

require 'rubygems'
require_gem 'activesupport', '= 1.3.0'
require_gem 'activerecord', '= 1.13.2'
require_gem 'actionpack', '= 1.11.2'
require_gem 'actionmailer', '= 1.1.5'
require_gem 'actionwebservice', '= 1.0.0'

So, where should I lock-down the gems to the Rails 1.0 versions?

Thanks,
Sean

/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:149:in `activate': can't
activate activesupport (= 1.2.5), already activated
activesupport-1.3.0] (Gem::Exception)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:167:in
`activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:166:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:166:in
`activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
`require_gem_with_options'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:31:in
`require_gem'
        from .../typo/public/../config/environment.rb:8
        from .../typo/public/dispatch.fcgi:21:in `require'
        from .../typo/public/dispatch.fcgi:21
A553df4fc75a4e3cd9e27ff3f0ba9206?d=identicon&s=25 Dean Strelau (Guest)
on 2006-03-29 05:24
(Received via mailing list)
`svn export http://dev.rubyonrails.org/svn/rails/tags/rel_1-0-0/
vendor/rails` from your RAILS_ROOT is supposed to do the trick, but
it's still not working for my on Dreamhost. I'd give it a try. It
*should* work.
5ce55767684e0cd1727db2b8b8975640?d=identicon&s=25 Steve Longdo (Guest)
on 2006-03-29 05:24
(Received via mailing list)
Try running:

rake freeze_edge REVISION=3303

On your Typo install directory.  This is the equivalent to the Rails
1.0gem.

-Steve
http://www.stevelongdo.com
902654bac6dff9567f018bd2ed933151?d=identicon&s=25 Nicholas Van Weerdenburg (Guest)
on 2006-03-29 06:02
(Received via mailing list)
Thanks!

This worked great on Textdrive for me.

And, strangely, I seem to be consuming less memory.

Thanks,
Nick
6195c5bcf8b404ab55ff1faf982413b1?d=identicon&s=25 Robert Ivanc (Guest)
on 2006-03-29 09:56
(Received via mailing list)
Hi,

I am not sure if this will be at all helpful, but my typo install on
dreamhost seems to be working just fine, in spite of the rails 1.1
upgrade. I do run a pretty old revision on it though,
r760. Maybe it help figuring out where the problems are, if they are
not already known.

Robert
6195c5bcf8b404ab55ff1faf982413b1?d=identicon&s=25 Robert Ivanc (Guest)
on 2006-03-29 12:32
(Received via mailing list)
never mind. old processes were still running...
This topic is locked and can not be replied to.