Forum: Ruby on Rails server not starting in new Rails 1.1 - lighttpd parser error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
69efb3b74703ceffbd6603d044a639f6?d=identicon&s=25 Gopal Balaji (gbalaji)
on 2006-03-28 16:09
I am newbie - needed help,

I just know updated rails1.1


When i start the server I'm getting this error,

------------------------------------------
gbalaji:~/projects/depot gopalbalaji$ ruby script/server
=> Booting lighttpd (use 'script/server webrick' to force WEBrick)
=> Rails application started on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
Undefined config variable: var.CWD
2006-03-28 19:36:15: (configfile.c.800) source: config/lighttpd.conf
line: 8 pos: 43 parser failed somehow near here: +
Exiting
-------------------------------------------

May I know what is the problem with my server starting.
5d15c6821f3c3054c04b85471824ba7c?d=identicon&s=25 Mikkel Bruun (Guest)
on 2006-03-28 16:21
(Received via mailing list)
You need a recent build of lighttpd for the script/server to
work...1.4.9 or higher i believe...

Note: this is only because of the way that the DEVELOPMENT lighttpd.conf
is written...

Rails can run on lightys ealier than 1.4.9

On Tuesday, March 28, 2006, at 4:09 PM, gopal balaji wrote:
>=> Rails application started on http://0.0.0.0:3000
>
>--
>Posted via http://www.ruby-forum.com/.
>_______________________________________________
>Rails mailing list
>Rails@lists.rubyonrails.org
>http://lists.rubyonrails.org/mailman/listinfo/rails


Mikkel Bruun

www.strongside.dk    - Football Portal(DK)
nflfeed.helenius.org - Football News(DK)
ting.minline.dk      - Buy Old Stuff!(DK)
This topic is locked and can not be replied to.