Forum: Ruby on Rails RE: Re: Chinese characters in the title

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
6ff739ae9ebd9522b6bac69ed2e7d25f?d=identicon&s=25 Dean Matsueda (Guest)
on 2006-03-24 23:43
(Received via mailing list)
> I don't see any problem of CNET Chinese title in my firefox
> under XP English version.

If it helps, I see the characters in the title at that URL, too, in both
Firefox 1.5 and MSIE 5.5 on a Windows 2000 box, English version, and
with Chinese language fonts installed.
F68e4842b0a5487678e26046fdb2fdf3?d=identicon&s=25 Frank (Guest)
on 2006-03-25 02:07
(Received via mailing list)
That's bizarre cause I am using Firefox (English) with XP too and I see
tiny boxes.

  What character-set is default on your machine?

  Frank

Dean Matsueda <dmatsueda@bsr.org> wrote:  > I don't see any problem of
CNET Chinese title in my firefox
> under XP English version.

If it helps, I see the characters in the title at that URL, too, in both
Firefox 1.5 and MSIE 5.5 on a Windows 2000 box, English version, and
with Chinese language fonts installed.
_______________________________________________
Rails mailing list
Rails@lists.rubyonrails.org
http://lists.rubyonrails.org/mailman/listinfo/rails



Want to read my Pro Rails book or Pro Server Management book? Become a
beta reader now. Write me to learn more.

Rails Blog: http://railsruby.blogspot.com
MySQL Blog: http://mysqldatabaseadministration.blogspot.com
Linux / Security Blog: http://frankmash.blogspot.com
Programming One Liners: http://programming-oneliners.blogspot.com
Cee38055ae36590c654c04c2d5cc2778?d=identicon&s=25 Sky Yin (cookoo)
on 2006-03-25 03:36
Frank, obviously you have to install Chinese fonts. Title bar is managed
by the OS, even though Firefox has its own Chinese fonts to show pages
correctly.

To do that in XP, it's quite simple. Choose 'Regional and Language
Options' in the control panel, then in the 'Languges' tab, check
'Install files for East Asian languages'. And later in the 'Advanced'
tab, select 'Chinese(PRC)' as the option of 'Language for non-Unicode
programs'. You may need an XP installation CD and have to restart once.

That's all for properly showing the title bar.

Frank wrote:
> That's bizarre cause I am using Firefox (English) with XP too and I see
> tiny boxes.
>
This topic is locked and can not be replied to.