Forum: Ruby on Rails [OT] building fastcgi

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ef0db53920b243d6758c2f6b1306df0d?d=identicon&s=25 Steve Ross (cwd)
on 2006-03-23 02:17
(Received via mailing list)
Following the instructions on Hivelogic, everything works flawlessly on
my
Powerbook until I do the 'sudo gem install fcgi.

I'm getting no-definition errors all over the place. Any thoughts how to
resolve this?

Example of errors:

No definition for fcgi_s_accept

No definition for fcgi_s_each

No definition for fcgi_s_each

No definition for fcgi_s_iscgi
--
View this message in context:
http://www.nabble.com/-OT-building-fastcgi-t132779...
Sent from the RubyOnRails Users forum at Nabble.com.
59de94a56fd2c198f33d9515d1c05961?d=identicon&s=25 Tom Mornini (Guest)
on 2006-03-23 02:41
(Received via mailing list)
Try this:

sudo gcc_select 3.3

whether it works or not...

sudo gcc_select 4.0

afterward to put it back into "stock" form.

--
-- Tom Mornini
Ef0db53920b243d6758c2f6b1306df0d?d=identicon&s=25 Steve Ross (cwd)
on 2006-03-23 02:46
(Received via mailing list)
gcc_select didn't solve the problem. Any other places to look?

Thanks
--
View this message in context:
http://www.nabble.com/-OT-building-fastcgi-t132779...
Sent from the RubyOnRails Users forum at Nabble.com.
59de94a56fd2c198f33d9515d1c05961?d=identicon&s=25 Tom Mornini (Guest)
on 2006-03-23 03:07
(Received via mailing list)
Did you install fcgi itself, before the gem?

--
-- Tom Mornini
Ef0db53920b243d6758c2f6b1306df0d?d=identicon&s=25 Steve Ross (cwd)
on 2006-03-23 03:51
(Received via mailing list)
>> Did you install fcgi itself, before the gem?

Yep. Clean build, clean install. Believe me, I've done the steps on
Hivelogic more often than once... Just can't get fastcgi running.
--
View this message in context:
http://www.nabble.com/-OT-building-fastcgi-t132779...
Sent from the RubyOnRails Users forum at Nabble.com.
Ef0db53920b243d6758c2f6b1306df0d?d=identicon&s=25 Steve Ross (cwd)
on 2006-03-24 01:47
(Received via mailing list)
Sorry to respond to my own post, but it looks like the gem may have
installed
correctly. Still, fastcgi is upchucking... The error I get is:

=> Booting lighttpd (use 'script/server webrick' to force WEBrick)
=> Rails application started on http://0.0.0.0:3005
=> Call with -d to detach (requires absolute paths in
config/lighttpd.conf)
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
2006-03-23 16:41:45: (mod_fastcgi.c.989) execve failed for:
public/dispatch.fcgi
 No such file or directory
2006-03-23 16:41:45: (mod_fastcgi.c.1015) the fastcgi-backend
public/dispatch.fc
gi failed to start:
2006-03-23 16:41:45: (mod_fastcgi.c.1019) child exited with status 2
public/disp
atch.fcgi
2006-03-23 16:41:45: (mod_fastcgi.c.1022) if you try do run PHP as
FastCGI
backe
nd make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing 'php -v' and it
should
disp
lay '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
For more information check
http://www.lighttpd.net/documentation/fastcgi.html#pr
eparing-php-as-a-fastcgi-program
2006-03-23 16:41:45: (mod_fastcgi.c.1027) If this is PHP on Gentoo add
fastcgi t
o the USE flags
2006-03-23 16:41:45: (mod_fastcgi.c.1314) [ERROR]: spawning fcgi failed.
2006-03-23 16:41:45: (server.c.670) Configuration of plugins failed.
Going
down.
--
View this message in context:
http://www.nabble.com/-OT-building-fastcgi-t132779...
Sent from the RubyOnRails Users forum at Nabble.com.
This topic is locked and can not be replied to.