Forum: Ruby on Rails login_engine

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
F719c6cb34bd5b691c12b373b7244b4d?d=identicon&s=25 Dorian Mcfarland (tachekent)
on 2006-03-20 19:17
(Received via mailing list)
Hello,
I'm having trouble getting login_engine to work properly. I get the
standard login/registration views, but whenever I try to register I get:

NoMethodError in User#signup
undefined method `password_confirmation=' for #<User:0x408b2f9c>

I have login_engine, and engines installed from cvs:
http://opensvn.csie.org/rails_engines/plugins/

anyone else had anything similar or know what I might be doing wrong?

dorian

--
I do things for love or money
Ac1da5d66d51a1c3b843221032247b30?d=identicon&s=25 Eric Goodwin (Guest)
on 2006-03-20 19:20
(Received via mailing list)
Hi,

Do you already have a app/models/user.rb in your main app?
If you do then the engine's user model will not get initiated, and it is
the one with the password_confirmation method in it.

Cheers,
Eric Goodwin

Dorian Mcfarland wrote:
> anyone else had anything similar or know what I might be doing wrong?
>
> dorian
>
> --
> I do things for love or money
> _______________________________________________
> Rails mailing list
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails


--
Eric Goodwin
http://www.ericgoodwin.com
93dd75955910bee12e49ef083ab8f65d?d=identicon&s=25 Cody P. Skidmore (Guest)
on 2006-03-20 19:27
I just got the login_engine working.  I tried the salted login engine
plugin  before using login_engine and had to clean out my project
directories before the login_engine could function properly.

You should do as Eric suggests and take a look at files in your project.
If you clean everything out and try re-installing the login_engine it
should deploy property.
F719c6cb34bd5b691c12b373b7244b4d?d=identicon&s=25 Dorian Mcfarland (tachekent)
on 2006-03-20 19:28
(Received via mailing list)
sorry,
I just saw the post from 4 days ago, which fixed it for me.
I keep doing that - I'll pay more attention in future.

d
This topic is locked and can not be replied to.