Forum: Ruby on Rails Getting a blank page for uknown reason

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
832cf770881fdde1e604873ac425d89b?d=identicon&s=25 Gabriel Boys (gabrielboys)
on 2006-03-18 22:59
I have a model that represents a Player, and within that there is a
method that calculates wins and losses for that player based on a how
they did in databases that are in the DB.  When this calculation is over
it is supposed to show a summary of the calculation.  When testing it on
my local machine using Webrick it works fine, but when I put it on my
web server, after the calculation is done it goes to a blank page
instead of the summary page.  The address is correct in the browser, it
just does not show anything.  I looked in the log and it said it was
rendering the page, but it just shows nothing.  My code is not the most
efficient in the world right now, is it because of the calculation is
taking a long time maybe?  Any ideas on this would be greatly

573b9499030e1ccb867ef80f0ff1ac49?d=identicon&s=25 Justin Bailey (Guest)
on 2006-03-18 23:04
(Received via mailing list)
Whenever I see somethign like that, its because I have an old session
lying around somewhere and Rails doesn't like it. Try deleting all your
cookies (or at least the ones associated with your production site).
7cda78d70ab775710f6fa24e0a5b68db?d=identicon&s=25 Emin Hasanov (Guest)
on 2006-03-18 23:04
(Received via mailing list)
very general question, so here comes general answer - you may not have
uploaded all the files properly and template really has nothing to show

Normally, you would cut down everything from your controller/template
you get to the _minimal_ code that does NOT work. This is when you find
42172acdf3c6046f84d644cb0b94642c?d=identicon&s=25 Pat Maddox (pergesu)
on 2006-03-18 23:10
(Received via mailing list)
rm /tmp/ruby_sess.*

It has to do with old objects in the session..always wondered why it's
impossible to get an error other than a blank screen.
832cf770881fdde1e604873ac425d89b?d=identicon&s=25 Gabriel Boys (gabrielboys)
on 2006-03-18 23:14
Cool thanks for the help.  I will try that out and see what I get.
832cf770881fdde1e604873ac425d89b?d=identicon&s=25 Gabriel Boys (gabrielboys)
on 2006-03-18 23:41
So I just imported all of the exact same tournament files to both my
local machine  and my web server(the code is identical, it is btoh
coming from my central svn repository).  Once again on my local machine
it worked.  Before I ran it on my web server I deleted all of my session
file from the tmp dir.  This time when I ran it I tailed the
development.log,the blank page came up before the calculation was done
running.  It came up, and I could see through the tailed file that it
was still computing away.  Eventually it finishes, and computes things
correctly, but the page does not get changed to the summary page,
presumably because it has already changed to the blank one.

This topic is locked and can not be replied to.