Forum: Ruby Tk on windows

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
E17632fab00b930ea3b30e1b98f39675?d=identicon&s=25 Jeppe Jakobsen (Guest)
on 2006-03-11 18:57
(Received via mailing list)
Hi there, I'm about to try my first toolkit tutorial, with tk. So, to
check
that I had it installed I wrote:

require "tk"

in my rb file, but I get an error loading tk84.dll.
How do I fix this?
47b1910084592eb77a032bc7d8d1a84e?d=identicon&s=25 Joel VanderWerf (Guest)
on 2006-03-11 19:55
(Received via mailing list)
Jeppe Jakobsen wrote:
>
If you are using recent one-click windows installers, the tk84.dll is no
longer included. Just install it from:

  http://www.activestate.com/Products/ActiveTcl
E17632fab00b930ea3b30e1b98f39675?d=identicon&s=25 Jeppe Jakobsen (Guest)
on 2006-03-11 21:39
(Received via mailing list)
Thank you, that took care of the problem :)

2006/3/11, Joel VanderWerf <vjoel@path.berkeley.edu>:
Dedb38b3571b323b77bc9b221e940172?d=identicon&s=25 ruby talk (Guest)
on 2006-03-18 00:52
(Received via mailing list)
I downloaded the ActiveTcl and installed it. Now i have a differnt
error,

c:/ruby/lib/ruby/1.8/tk.rb:1102:in `initialize': tcltklib: fail to
Tk_Init(). version conflict for package "Tcl": have 8.4, need 8.3
(RuntimeError)
	from c:/ruby/lib/ruby/1.8/tk.rb:1102
	from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
	from gmailer.rb:1

I miss the one click installer :( can we get a version with TK? Was
there a reason it was removed?

Becker
52a177e9dbd3e614825aabc4e45f8cd6?d=identicon&s=25 Mark Volkmann (Guest)
on 2006-03-18 01:04
(Received via mailing list)
On 3/17/06, ruby talk <rubytalk@gmail.com> wrote:
> there a reason it was removed?
Interesting. I also installed Ruby from the latest version of the one
click installer, downloaded ActiveTcl for Windows and installed it.
Ruby is working fine with Tk for me. Sorry I can't be of more help.
Dedb38b3571b323b77bc9b221e940172?d=identicon&s=25 ruby talk (Guest)
on 2006-03-18 02:23
(Received via mailing list)
I uninstalled ruby,( i did install over the old version), and
uninstalled. I also uninstalled activeTcl. rebooted downloaded the
installers, and its working again.

Becker
This topic is locked and can not be replied to.