Forum: Rails Germany Rails 3 Ruby 1.9.2 Lighttpd 1.4 FCGI? Rack? Ubuntu 10.10?

53df151b6f5b0d39f42b1e26b1637ee2?d=identicon&s=25 Thomas Sojka (toxsox)
on 2010-12-02 13:55
Ich habe bereits einen Server wo ich Rails 2.3.2 mit Ruby 1.8 auf nem
lighttpd mit fcgi am laufen hab. In Rails 2.3.2 gibt es ja auch noch
eine tolle dispatch.fcgi die man als fcgi ansteuern kann und es macht
keine Probleme.

Doch bin ich gerade dabei einen neuen Server aufzusetzen und da meine
aktuellen Entwicklungen auf Rails 3.0.3 mit Ruby 1.9.2 basieren wollte
ich dieses nun auch auf mein Ubuntu Server 10.10 machen. Doch leider
scheitere ich an der Einrichtung im zusammenhang mit lighttpd und fcgi.
Ruby und Rails sind alles installiert und ich kann mit rails s auch den
WEBrick starten.

Nur gibt es keine dispatch.fcgi oder ähnliches was man ansteuern kann.
Desweiteren habe ich gelesen das man Rack verwenden sollte um Rails per
FCGI anzusteuern, doch ich habe nirgendwo ein Beispiel gefunden wie man
sowas machen soll.

Habe schon 2 Tage gesucht aber ich finde nichts :(

Vielleicht kann mir ja hier jemand helfen.

LG
This topic is locked and can not be replied to.