Forum: Ruby on Rails auto launch lighttpd in RC4

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
F85e4d039cb54389389010fc095b6b6a?d=identicon&s=25 moosebrookfarm (Guest)
on 2005-11-18 18:35
(Received via mailing list)
Hi -

I run rails on OS X Tiger.  I downloaded and built/installed from
source the lighttpd server.
It's stored in /usr/local/sbin which is in my .bash_profile PATH

Office:~ mengelhart$ which lighttpd
/usr/local/sbin/lighttpd


I've updated to the Rails RC4 release as per the instructions and
everything is fine except that Webrick is the app server that gets
launched.

Any idea why script/server won't launch lighttpd?   Also the
documentation says that a lighttpd.conf is installed into config but I
don't see it there.  I've tried even creating a whole new project and
it will only lauch Webrick.

Thanks
Mike
3fdda7e032a5619199486d05b506ced4?d=identicon&s=25 Brad Daily (Guest)
on 2005-11-18 23:30
I did this very thing today, and it worked. Two things come to mind:

1) Do you have the prce libs installed? You have to do this before
configuring and installing lighty.
2) Did you try ruby script/server lighttpd to see if you can force
lighty to run?

Here is a post, while a little out of date, that helped me:
http://theexciter.com/articles/installing-lighttpd-on-osx
450046d5f684ae5001c0b1a079d447d4?d=identicon&s=25 sean (Guest)
on 2005-11-19 02:26
(Received via mailing list)
Probably a really dumb question but I do this all the time so...
After you added your path to .bash_profile, did you remember to login
again?

:-)

Sean


On Nov 19, 2005, at 7:30 AM, Brad Daily wrote:

> moosebrookfarm wrote:
>> I've updated to the Rails RC4 release as per the instructions and
>> Mike
>
>
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Rails mailing list
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails
>
>

::::  DataFly.Net  ::::
Complete Web Services
http://www.datafly.net
F85e4d039cb54389389010fc095b6b6a?d=identicon&s=25 moosebrookfarm (Guest)
on 2005-11-19 03:41
(Received via mailing list)
Actually I didn't have prce libs or fcgi installed!  I followed the
instructions on that link and it works perfectly.  Thank you.
Mike
This topic is locked and can not be replied to.