I need to install rails on my system for a class project. I have ruby 1.8.2-14 installed and am entering at the command prompt >gem install rails --remote According to Curt Hibbs installation, I should get a series of questions to answer yes to, and then info on the installation. All I am getting is... Successfully installed rails_analyzer_tools, version 1.1.0 Installing RDoc documentation for rails_analyzer_tools-1.1.0... Any help would be greatly appreciated.
on 2006-03-02 04:43
on 2006-03-02 04:55
Try the following - it should automatically download all the required dependencies: gem install rails --include-dependencies
on 2006-03-02 05:00
The problem is that you have an outdated version of rubygems. Upgrade to the latest, then rinse, repeat. -Sean
on 2006-03-02 05:00
I have tried that. I get.. ERROR: While executing gem ... (OptionParser::InvalidOption) invalid option: --include-dependencies
on 2006-03-02 05:24
A simple option is to just download Instant Rails and run it from there. No installation required; just unzip into a directory and run it. It's about as simple as an installation can get... It contains several of the commonly used gems; at the very least, it'll get you going while you try to sort out the problem you've got. Regards Dave M.
on 2006-03-02 05:36
Sean Stephens wrote: > The problem is that you have an outdated version of rubygems. > Upgrade to the latest, then rinse, repeat. > > -Sean Thank you much. 'Tis working.
on 2008-03-20 16:24
Hi, firstname.lastname@example.org is not a ML for reporting problems. If you want to use mail for reporting them, please use email@example.com. If you want to use Web interface, use a tracker on SF.net. In <firstname.lastname@example.org> "installation problem" on Wed, 19 Mar 2008 16:24:24 +0100, "Sergueï_Cambour" <email@example.com> wrote: > from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in > `require' > from c:/ruby/lib/ruby/site_ruby/1.8/gtk2.rb:2 > from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in > `gem_original_require' > from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in > `require' > from -e:1 > [/code] > > Can you please explain me what I did wrong ? What version are you using? Thanks, -- kou
on 2008-03-22 04:48
Hi, Remove Ruby-GNOME2 related files in c:/ruby/lib/ruby/site_ruby/1.8/. Perhaps you installed them before you use Win32 installer. Thanks, -- kou In <firstname.lastname@example.org> "Re: installation problem" on Fri, 21 Mar 2008 09:53:17 +0100,