Forum: Ruby Ruby Path

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
4ea56c658e69eef33b6557b20c7a19ab?d=identicon&s=25 unknown (Guest)
on 2006-03-01 18:58
(Received via mailing list)
My ruby applications have suddenly stopped running on my PC.  It looks
like the gem libraries are no longer in the path.  My gems are
installed to this directory C:\ruby\lib\ruby\gems\1.8\gems\

I never had to setup a manual path for this, it was "auto-magically"
handled by Ruby.  Any ideas what would cause this to just quit working
like this and how to fix it?  Is there some Ruby config file that loads
the paths etc...

Thanks!
10d4acbfdaccb4eee687a428ca00a5d8?d=identicon&s=25 Jim Weirich (weirich)
on 2006-03-01 19:57
unknown wrote:
> My ruby applications have suddenly stopped running on my PC.  It looks
> like the gem libraries are no longer in the path.  My gems are
> installed to this directory C:\ruby\lib\ruby\gems\1.8\gems\
>
> I never had to setup a manual path for this, it was "auto-magically"
> handled by Ruby.  Any ideas what would cause this to just quit working
> like this and how to fix it?  Is there some Ruby config file that loads
> the paths etc...

Libraries in the gem directories need to use the RubyGems runtime to
find them. The one click installer implicitly loads RubyGems by setting
the RUBYOPT environment variable to 'rubygems'.  Is is possible this
environment variable is no longer set?

---
-- Jim Weirich
4ea56c658e69eef33b6557b20c7a19ab?d=identicon&s=25 unknown (Guest)
on 2006-03-01 22:18
(Received via mailing list)
Jim,

Thanks for the help!  The RUBYOPT environment variable must be set
behind the scenes somewhere.  I did not have it set in my Windows
environment variables previously, but had just recently added it and
set it to "w" to get more detailed warning messages.  After changing
this to "rubygems" everything worked great again.

Joe
52a177e9dbd3e614825aabc4e45f8cd6?d=identicon&s=25 Mark Volkmann (Guest)
on 2006-03-02 01:44
(Received via mailing list)
On 3/1/06, Joiey.Seeley@gmail.com <Joiey.Seeley@gmail.com> wrote:
> Jim,
>
> Thanks for the help!  The RUBYOPT environment variable must be set
> behind the scenes somewhere.  I did not have it set in my Windows
> environment variables previously, but had just recently added it and
> set it to "w" to get more detailed warning messages.  After changing
> this to "rubygems" everything worked great again.

How do you put two options in RUBTOPT?  What's the delimiter?
For example, what if I wanted both "rubygems" and "w"?
"rubygems w" and "rubygems, w" don't work under Windows in Ruby 1.8.4.
C475cffda1800fbc3f3af17bc10c220f?d=identicon&s=25 Curt Hibbs (Guest)
on 2006-03-02 05:05
(Received via mailing list)
On 3/1/06, Mark Volkmann <r.mark.volkmann@gmail.com> wrote:
> For example, what if I wanted both "rubygems" and "w"?
> "rubygems w" and "rubygems, w" don't work under Windows in Ruby 1.8.4.

If you want to put multiple options in RUBYOPT then you must use the
"-" character on the options. So, in this case you'd have to set it to
"-rubygems -w".

Curt
This topic is locked and can not be replied to.