Forum: Ruby on Rails Rails on 2003

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
09e6ba06911a5781c04be8554f114aba?d=identicon&s=25 Rob Nichols (reggieb)
on 2006-03-01 10:32
The site describing how to set up IIS on Windows 2003 for Rails appears
to be down:

http://www.bitslapped.nl/articles/2005/06/05/rails...

Does anyone know anywhere else where this information can be found?
F16def8015a7562a285c65a14be48540?d=identicon&s=25 Mathieu Chappuis (Guest)
on 2006-03-01 12:18
(Received via mailing list)
Hi,

Try googling "Rails on IIS Revisited"

And the doc section on the site "RubyforIIS" is inspired from you dead
link.
09e6ba06911a5781c04be8554f114aba?d=identicon&s=25 Rob Nichols (reggieb)
on 2006-03-01 13:31
Mathieu Chappuis wrote:
> Hi,
>
> Try googling "Rails on IIS Revisited"
>
> And the doc section on the site "RubyforIIS" is inspired from you dead
> link.

Thank you.

I've found this from the the RubyforIIS wiki page:

http://rubyforiis.sosukodo.org/rubyforiis/document...

and am working my way through it.
09e6ba06911a5781c04be8554f114aba?d=identicon&s=25 Rob Nichols (reggieb)
on 2006-03-01 16:57
I stuggle all day with it and could not get it to work. Installed Apache
1.3.x (using port 8080) and used that instead. Seems to be working fine.
F16def8015a7562a285c65a14be48540?d=identicon&s=25 Mathieu Chappuis (Guest)
on 2006-03-01 17:14
(Received via mailing list)
> I stuggle all day with it and could not get it to work. Installed Apache
> 1.3.x (using port 8080) and used that instead. Seems to be working fine.

My sysadmins wont ear about Apache, so I fall into IIS 6.0.

I was new to that http server, and after fighting some hours, my Ror
App works quite fast with 2003/IIS 6, credits to ISAPI_FastCGI and
Rails contributors for docs.

The most critical point is : "What damned checkbox, in what setup
screen, I've clicked for making that stuff working now."

I'm still busy to fix some minor things like ?page=3 pagination
parameter is not recognized..

If you like to post your symptoms, I would help if I can.

Cheers,
771d3934c5bd53b76c95b4429c38ae0c?d=identicon&s=25 Erwin Quita (erwinquita)
on 2006-03-02 01:49
(Received via mailing list)
Mathieu Chappuis wrote:
> The most critical point is : "What damned checkbox, in what setup
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails
>
>
Hi Mathiew,

    Can you give us your requirements, I had problems making ror work
under iis, I really need a clear step by step procedure on how to make
it work. Any help would be appreciated. thanks!

regards,
Erwin
F16def8015a7562a285c65a14be48540?d=identicon&s=25 Mathieu Chappuis (Guest)
on 2006-03-02 08:47
(Received via mailing list)
>     Can you give us your requirements, I had problems making ror work
> under iis, I really need a clear step by step procedure on how to make
> it work. Any help would be appreciated. thanks!

W2003/IIS 6.0 (P4 w 512mb)

Ruby 1.8.2 (One Click installer)
Rubygems 0.8.11 installed from tgz
Rails 1.0 via Rubygems

ISAPI_FastCGI
ISAPI_Rewrite (i bought the full version, but eval works)

RubyforIIS

The step by step is covered in the link posted in this tread. The most
detailled is "Rails on IIS Revisited".

Very important is the patch for request.rb in the actionpack lib, you
ca found it in this document.

Cheers,
This topic is locked and can not be replied to.