Forum: Ruby on Rails Ruby site structure on Apache

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
3331bac71517b12fbacdd0e6069353e3?d=identicon&s=25 Mark Sheran (marksh)
on 2006-02-24 20:31
I use a hosting company,it use appache for RoR

I test a 'hello word' code here

http://www.smtservers.com/demo/

I can see the working code here

http://www.smtservers.com/demo/public/say/hello

My question is how to short the url like

http://www.smtservers.com/demo/say/hello.I do not like public always in
URL

Thanks for help

Mark
42172acdf3c6046f84d644cb0b94642c?d=identicon&s=25 Pat Maddox (pergesu)
on 2006-02-24 20:38
(Received via mailing list)
You need to make the document root RAILS_ROOT/public, not RAILS_ROOT.
There's absolutely no reason your rails code needs to be available
over HTTP, and in fact is a security risk.  Consider that anyone can
go to config/database.yml and see your connection info.

If you can't explicitly set the docroot to RAILS_ROOT/public, then you
should put your app in a non HTTP-accessible folder and use a symlink.

Pat
3331bac71517b12fbacdd0e6069353e3?d=identicon&s=25 Mark Sheran (marksh)
on 2006-02-24 20:54
How to use symlink.I do not understand.Thanks

Mark
Pat Maddox wrote:
> You need to make the document root RAILS_ROOT/public, not RAILS_ROOT.
> There's absolutely no reason your rails code needs to be available
> over HTTP, and in fact is a security risk.  Consider that anyone can
> go to config/database.yml and see your connection info.
>
> If you can't explicitly set the docroot to RAILS_ROOT/public, then you
> should put your app in a non HTTP-accessible folder and use a symlink.
>
> Pat
119af50160cabfe1fb6f2f05f5018c64?d=identicon&s=25 James Ludlow (Guest)
on 2006-02-24 21:06
(Received via mailing list)
On 2/24/06, mark sheran <markshen2004@gmail.com> wrote:
> How to use symlink.I do not understand.Thanks

The command is "ln -s".  Try "man ln" or Google to figure out how to use
it.

I have to reiterate a suggestion already made to you, which is that
you should figure out how Rails and Ruby work first before worrying
about all of these deployment issues.  That stuff is so far down the
line before it's ever going to matter to you.

Posting several variations of "My server is broke, why?" isn't really
helping other people help you.  If you have specific error messages or
log entries that don't make sense to you, post those.

-- James
3331bac71517b12fbacdd0e6069353e3?d=identicon&s=25 Mark Sheran (marksh)
on 2006-02-24 22:34
James Ludlow wrote:
> On 2/24/06, mark sheran <markshen2004@gmail.com> wrote:
>> How to use symlink.I do not understand.Thanks
>
> The command is "ln -s".  Try "man ln" or Google to figure out how to use
> it.
>
> I have to reiterate a suggestion already made to you, which is that
> you should figure out how Rails and Ruby work first before worrying
> about all of these deployment issues.  That stuff is so far down the
> line before it's ever going to matter to you.
>
> Posting several variations of "My server is broke, why?" isn't really
> helping other people help you.  If you have specific error messages or
> log entries that don't make sense to you, post those.
>
> -- James

ln is a shell command,I know it affect shell command but I do not know
how it affect URL access.do I have to change someconfig file of Apache?

Thanks

Mark
132a94ca65959bda6c74fae54bff2425?d=identicon&s=25 Ezra Zygmuntowicz (Guest)
on 2006-02-25 00:29
(Received via mailing list)
On Feb 24, 2006, at 1:34 PM, mark sheran wrote:

>> about all of these deployment issues.  That stuff is so far down the
> how it affect URL access.do I have to change someconfig file of
> Apache?
>
> Thanks
>
> Mark


OK Mark-

	Lets see if we can solve this for you once and for all. but i agree
with everyone else here in saying that you shoudlnt worry about
deploying to your web hosts server until you are more experienced.
You should use webrick to develop locally and then worry about it a
bit later when you've gotten your feet wet.

	As to the current problem of ln-s for the symlink:


Lets assume that your directory structure is like this:  /home/mark/
htdocs  What you will want to do is place your rails application
right inside your home folder liek this:

/home/mark/railsapp

Now you need to symlink your railsapp/public directory to the htdocs
folder of your home dir with this command

ln -s /home/mark/railsapp/public /home/mark/htdocs

Then you should be set up to run your hello world.

Cheers0
-Ezra Zygmuntowicz
Yakima Herald-Republic
WebMaster
http://yakimaherald.com
509-577-7732
ezra@yakima-herald.com
3331bac71517b12fbacdd0e6069353e3?d=identicon&s=25 Mark Sheran (marksh)
on 2006-02-25 03:37
Do you mean I only run the command once

ln -s /home/mark/railsapp/public /home/mark/htdocs

then the server can remember forever.I do not need change setting files.

I ask my hosting company.he ask me change .htaccess.I do not know how.

Thanks

Mark




Ezra Zygmuntowicz wrote:
> On Feb 24, 2006, at 1:34 PM, mark sheran wrote:
>
>>> about all of these deployment issues.  That stuff is so far down the
>> how it affect URL access.do I have to change someconfig file of
>> Apache?
>>
>> Thanks
>>
>> Mark
>
>
> OK Mark-
>
> 	Lets see if we can solve this for you once and for all. but i agree
> with everyone else here in saying that you shoudlnt worry about
> deploying to your web hosts server until you are more experienced.
> You should use webrick to develop locally and then worry about it a
> bit later when you've gotten your feet wet.
>
> 	As to the current problem of ln-s for the symlink:
>
>
> Lets assume that your directory structure is like this:  /home/mark/
> htdocs  What you will want to do is place your rails application
> right inside your home folder liek this:
>
> /home/mark/railsapp
>
> Now you need to symlink your railsapp/public directory to the htdocs
> folder of your home dir with this command
>
> ln -s /home/mark/railsapp/public /home/mark/htdocs
>
> Then you should be set up to run your hello world.
>
> Cheers0
> -Ezra Zygmuntowicz
> Yakima Herald-Republic
> WebMaster
> http://yakimaherald.com
> 509-577-7732
> ezra@yakima-herald.com
3331bac71517b12fbacdd0e6069353e3?d=identicon&s=25 Mark Sheran (marksh)
on 2006-02-25 03:58
I get the error when I try ln -s /home/mark/railsapp/public
/home/mark/htdocs

"hard link not allowed for directory"

how to do with this?Thanks

Mark

mark sheran wrote:
> Do you mean I only run the command once
>
> ln -s /home/mark/railsapp/public /home/mark/htdocs
>
> then the server can remember forever.I do not need change setting files.
>
> I ask my hosting company.he ask me change .htaccess.I do not know how.
>
> Thanks
>
> Mark
>
>
>
>
> Ezra Zygmuntowicz wrote:
>> On Feb 24, 2006, at 1:34 PM, mark sheran wrote:
>>
>>>> about all of these deployment issues.  That stuff is so far down the
>>> how it affect URL access.do I have to change someconfig file of
>>> Apache?
>>>
>>> Thanks
>>>
>>> Mark
>>
>>
>> OK Mark-
>>
>> 	Lets see if we can solve this for you once and for all. but i agree
>> with everyone else here in saying that you shoudlnt worry about
>> deploying to your web hosts server until you are more experienced.
>> You should use webrick to develop locally and then worry about it a
>> bit later when you've gotten your feet wet.
>>
>> 	As to the current problem of ln-s for the symlink:
>>
>>
>> Lets assume that your directory structure is like this:  /home/mark/
>> htdocs  What you will want to do is place your rails application
>> right inside your home folder liek this:
>>
>> /home/mark/railsapp
>>
>> Now you need to symlink your railsapp/public directory to the htdocs
>> folder of your home dir with this command
>>
>> ln -s /home/mark/railsapp/public /home/mark/htdocs
>>
>> Then you should be set up to run your hello world.
>>
>> Cheers0
>> -Ezra Zygmuntowicz
>> Yakima Herald-Republic
>> WebMaster
>> http://yakimaherald.com
>> 509-577-7732
>> ezra@yakima-herald.com
8e44c65ac5b896da534ef2440121c953?d=identicon&s=25 Ezra Zygmuntowicz (Guest)
on 2006-02-25 06:19
(Received via mailing list)
I think you might need to erase the /home/mark/htdocs folder and then
run the command again. AQnd it will only need to be done once and it
will stay set.

-Ezra
This topic is locked and can not be replied to.