Forum: Ruby on Rails Help with SCGI please :(

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
C5380b957ff8ce5cb14cf2282ffeb720?d=identicon&s=25 Iván Vega Rivera (Guest)
on 2006-02-23 03:02
(Received via mailing list)
Hi,

While learning Ruby and Rails, I decided I just as well learn Linux
along the way... It's been fun, but I'm stuck at one of those
exasperating moments... I hope someone can help me :)

I installed Ruby 1.8.4 on Fedora Core 4, then Rails, then lighty, and
then SCGI.

I used yum to install lighty... and it already comes with mod_scgi.

I created my first application in /home/tango/ and I configured lighty
using the instructions here:

http://www.zedshaw.com/projects/scgi_rails/lighttpd.html

However, when I try to start lighty, I get the following error:

(mod_scgi.c.1050) missing key (short): scgi.server dispatch.scgi 0 port
2006-02-22 17:06:50: (server.c.834) Configuration of plugins failed.
Going down.

On lighttpd.conf I have the following relevant lines:

server.document-root = "/home/tango/public/"
server.error-handler-404 = "/dispatch.scgi"
scgi.server = ( "dispatch.scgi" => (( "host" => "127.0.0.1", "port" =>
9999, "check-local" => "disable" )) )

What of all things could I possibly be doing wrong?

Kind regards,
Ivan V.
3fdda7e032a5619199486d05b506ced4?d=identicon&s=25 Brad Daily (bdaily)
on 2006-02-23 03:30
Did you use:

scgi_ctrl config

and

scgi_ctrl start

as described in the Setup SCGI in Rails section of this page:
http://www.zedshaw.com/projects/scgi_rails/howto.html

Iván Vega Rivera wrote:
> Hi,
>
> While learning Ruby and Rails, I decided I just as well learn Linux
> along the way... It's been fun, but I'm stuck at one of those
> exasperating moments... I hope someone can help me :)
>
> I installed Ruby 1.8.4 on Fedora Core 4, then Rails, then lighty, and
> then SCGI.
>
> I used yum to install lighty... and it already comes with mod_scgi.
>
> I created my first application in /home/tango/ and I configured lighty
> using the instructions here:
>
> http://www.zedshaw.com/projects/scgi_rails/lighttpd.html
>
> However, when I try to start lighty, I get the following error:
>
> (mod_scgi.c.1050) missing key (short): scgi.server dispatch.scgi 0 port
> 2006-02-22 17:06:50: (server.c.834) Configuration of plugins failed.
> Going down.
>
> On lighttpd.conf I have the following relevant lines:
>
> server.document-root = "/home/tango/public/"
> server.error-handler-404 = "/dispatch.scgi"
> scgi.server = ( "dispatch.scgi" => (( "host" => "127.0.0.1", "port" =>
> 9999, "check-local" => "disable" )) )
>
> What of all things could I possibly be doing wrong?
>
> Kind regards,
> Ivan V.
C5380b957ff8ce5cb14cf2282ffeb720?d=identicon&s=25 Iván Vega Rivera (Guest)
on 2006-02-23 03:38
(Received via mailing list)
Yep, that's what I did.

Brad Daily escribió:
9dbe5b9021bf8477a3b7e747b44bde48?d=identicon&s=25 Sean O'Hara (Guest)
on 2006-02-23 03:44
(Received via mailing list)
Hi Ivan

I haven't used lighty with scgi, but I am running it on core 4, and I
couldn't get it to run rails and fcgi using the version available
from default core 4 repository.... it was 1.2.something, which is
several months old I think. So I resinstalled from the tarball on the
lighty web site, and everything worked just fine. I don't know what
version you're running, but ifit's real old maybe an upgrade will help?

Take care,
Sean
8c43ed7f065406bf171c0f3eb32cf615?d=identicon&s=25 Zed Shaw (Guest)
on 2006-02-23 07:13
(Received via mailing list)
That looks to be about right, but maybe the SCGI syntax has changed for
lighttpd.  Take a look at these instructions from turbogears:

http://www.cleverdevil.org/computing/34/deploying-...
nd-scgi

And see how he's got the $HTTP["url"] syntax?  Try something like that
just
to see if you can get it to at least talk to the scgi.  If you can then
look
at the scgi.server = block and see if some of those changes fix it.

I may have to update the instructions soon if they have changed.

Zed A. Shaw
http://www.zedshaw.com/
C5380b957ff8ce5cb14cf2282ffeb720?d=identicon&s=25 Iván Vega Rivera (Guest)
on 2006-02-23 15:13
(Received via mailing list)
Hah! That works!

Thanks a lot!

Ivan V.

Zed Shaw
escribió:> That looks to be about right, but maybe the SCGI syntax has changed 
for
This topic is locked and can not be replied to.