Forum: Ruby on Rails Urgent help needed

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
722873c7787fcfac50a49ddc4a09353c?d=identicon&s=25 Luc Boudreau (Guest)
on 2006-02-22 02:52
(Received via mailing list)
Hi,

I'm on Apache 2.0.54, Linux Fedora Core 2 with Plesk.

I installed a Rails application previously on the box using SCGI and
it works fine; even now.

I'm trying to get a second app online and it fails. Same config,
except for the SCGI runner ports of course.

It looks like the error comes from the fact that the mod_rewrite
loops. WHY ???

BTW : I have to put this app online ASAP.

Here's my .htaccess :

---------------------------------------------------
Options +FollowSymLinks +ExecCGI
RewriteEngine On
RewriteRule ^(.*)$ /scgi-bin/%{REQUEST_URI} [QSA,L]
---------------------------------------------------

Here's my scgi.yaml :
---------------------------------------------------
:port: 9998
:config: config/scgi.yaml
:logfile: log/scgi.log
:env: production
:control_url: druby://127.0.0.1:9988
:host: 127.0.0.1
:password: R8nZHBEEvF0k2
---------------------------------------------------

Here's my vhost setup :
---------------------------------------------------
   #ServerName hoster-demo
    DocumentRoot /home/httpd/vhosts/lecteurs.ca/subdomains/test/
httpdocs/public

    SCGIMount /scgi-bin/ 127.0.0.1:9998

    # matches locations with a dot following at least one more
characters, that is, things like   *,html, *.css, *.js, which should
be delivered directly from the filesystem
    <LocationMatch \..+$>
        # don't handle those with SCGI
        SCGIHandler Off
    </LocationMatch>

    <Directory /home/httpd/vhosts/lecteurs.ca/subdomains/test/
httpdocs/public/>
        Options +FollowSymLinks
        Order allow,deny
        allow from all
    </Directory>
---------------------------------------------------

Here's the access log entry :
---------------------------------------------------
66.254.44.203 - - [21/Feb/2006:20:49:29 -0500] "GET /user/list HTTP/
1.1" 404 235 "-" "Mozilla/5.0
---------------------------------------------------

Here's the error log entry :
---------------------------------------------------
[Tue Feb 21 20:49:29 2006] [error] [client 66.254.44.203]
mod_rewrite: maximum number of internal redirects reached. Assuming
configuration error. Use 'RewriteOptions MaxRedirects' to increase
the limit if neccessary.
Bf66e10c8fc4abefebde0425e7f6f15a?d=identicon&s=25 Norman Timmler (Guest)
on 2006-02-22 12:33
(Received via mailing list)
Am Dienstag, den 21.02.2006, 20:52 -0500 schrieb Luc Boudreau:
>
> Here's my scgi.yaml :
> Here's my vhost setup :
>     <LocationMatch \..+$>
> ---------------------------------------------------
> mod_rewrite: maximum number of internal redirects reached. Assuming
> configuration error. Use 'RewriteOptions MaxRedirects' to increase
> the limit if neccessary.
> ---------------------------------------------------

Use the Apache RewriteLog directive and see what is causing this error:

http://httpd.apache.org/docs/2.0/mod/mod_rewrite.h...

--
Norman Timmler

http://blog.inlet-media.de
This topic is locked and can not be replied to.