Forum: Ruby-core Bug in ruby

F0987c97234fa9c6b26f796bdbdab037?d=identicon&s=25 unknown (Guest)
on 2014-08-18 23:22
(Received via mailing list)
Issue #10133 has been updated by Andrew Vit.

The top stack frame shows Rails ActionDispatch middleware. This line is

It might help to test your code in a standalone ruby script without all
of Rails in order to narrow down the problem if it's actually happening
in DL or breaking something in Rails.

Bug #10133: Bug in ruby

* Author: Liz Huang
* Status: Feedback
* Priority: Normal
* Assignee:
* Category:
* Target version:
* ruby -v: 2.1.0p0 (2013-12-25 revision 44422
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN

I got a new Mac Pro server and tried to upgrade web applets to new
version of Ruby On Rails, the web applet calls an external Fortran
library I developed, it worked in Ruby on Rails (Ruby 1.8.7 and Rails
2.3.18) by using "DL". I tried to develop the same web applet in Ruby on
Rails 4 (ruby 2.1.0p0 (2013-12-25 revision 44422) and Rails 4.1.2), with
"DL" deprecated, so I use fiddle and wrapped Fortran by C, I tested the
interface by commenting out all computation parts first to make sure it
is working. Now I have the computation codes back (same codes as in
older version) and I even create a console application to test the code
is working. But when I try to call it from Ruby, it crashed.
I saved all messages in terminal window in attached file "bug.rtf" and
also send the crash report.
I feel it might a bug in Ruby as it works in older version and the
Fortran codes was tested in console application project.

bug.rtf (125 KB)
ruby_2014-08-14-162519_calder229.crash (25 KB) (1.21 MB)
This topic is locked and can not be replied to.