Forum: NGINX Disable Upstream Timeouts in Custom Module

0832abf14275f3c695eba2f4c0655fed?d=identicon&s=25 Jared McIntyre (Guest)
on 2014-08-15 23:02
(Received via mailing list)
I have a custom module that is proxying an upstream TCP based server. I
can manipulate the timeouts by changing the ngx_http_upstream_conf_t's
read_timeout and send_timeout to increase the timeout. However, for my
particular use case, it would be better if there is no artificial
timeout based on the length of time between received and sent packets.
As long as the TCP connection is still live, there should be no 504. Is
there any way to disable the send and read timouts in their entirety?


Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.