Forum: Ruby Apache 2.2 and mod_fastcgi

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
4f4122bc3b9999d9050f0b1a10b63251?d=identicon&s=25 Andrea Reginato (reis)
on 2006-02-02 00:35
(Received via mailing list)
I'm trying to install mod_fastcgi for my rails app.

I use Apache 2.2 and FastCGI 2.4.2 in windows xp.
I have modified the httpd.conf adding LoadModule fastcgi_module
modules/mod_fastcgi.dll (with mod_fastcgi.dll and mod_fastcgi.so in the
modules directory).

Whe i try to start Apache i have this error
----------------------------
apache: Syntax error on line 122 of C:/xampp/apache/conf/httpd.conf:
Cannot load C:/xampp/apache/modules/mod_fastcgi.dll into server:
Impossible to find the module.
----------------------------
But the file is in the dir modules. So Apache not start becouse don't
load fastcgi.

Then I have find in the web this link
http://groups.google.it/group/mailing.freebsd.port...
but I have not understand the solution. Then it ask for unix.

Thanks to all for the time.
--Reis.
E658897fe7d7539a2227538417d437db?d=identicon&s=25 X-Man (Guest)
on 2006-02-02 00:38
(Received via mailing list)
I installed Apache a few weeks ago. Everything worked perfectly (on
Windows XP service pack 2) for Ruby on Rails with FastCGI. Didn't have
to patch anything. I don't remember clearly, but probably, I didn't
have to install mod_fastcgi separately ... it came with the Apache for
Windows installation. I believe I have version 2.0.55.

Don't understand why you mentioned "mod_fastcgi.dll" because I don't
have such a file in my system. As far as I know, there's mod_fastcgi.so
only.
4f4122bc3b9999d9050f0b1a10b63251?d=identicon&s=25 Andrea Reginato (reis)
on 2006-02-02 00:41
(Received via mailing list)
X-Man ha scritto:

> I installed Apache a few weeks ago. Everything worked perfectly (on
> Windows XP service pack 2) for Ruby on Rails with FastCGI. Didn't have
> to patch anything. I don't remember clearly, but probably, I didn't
> have to install mod_fastcgi separately ... it came with the Apache for
> Windows installation. I believe I have version 2.0.55.
>

I think is this the problem. I have Apache 2.2 and the problem for me
is here (i thing it has deprecated a directive that is usefol for
reading mod_fastcgi).
The next day I will try with Apache 2.0...

> Don't understand why you mentioned "mod_fastcgi.dll" because I don't
> have such a file in my system. As far as I know, there's mod_fastcgi.so
> only.

I have read this in the rails wiki were they say to use the dll (i
don't know the motivation)
http://wiki.rubyonrails.org/rails/pages/Fast+CGI+a...

I have tried also with mod_fastcgi.so, but I have the same error.

Thanks so much for the help.
--Reis
E658897fe7d7539a2227538417d437db?d=identicon&s=25 X-Man (Guest)
on 2006-02-02 00:44
(Received via mailing list)
I just recalled now. I actually got the FastCGI component for Apache
from this site

http://rubyforge.org/frs/?group_id=477

I learned about this from reading this how-to

http://electricvisions.com/rails.html

No patching was required on my part. I just installed, and it worked.
This topic is locked and can not be replied to.