Forum: Ruby ri bug?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
47b1910084592eb77a032bc7d8d1a84e?d=identicon&s=25 Joel VanderWerf (Guest)
on 2006-01-31 08:05
(Received via mailing list)
This is with ruby built from source on linux (ubuntu 5.10):

$ ruby -v
ruby 1.8.4 (2005-12-24) [i686-linux]
$ ri Set
/usr/local/lib/ruby/1.8/rdoc/ri/ri_formatter.rb:80:in `conv_html':
private method `gsub' called for ["Example"]:Array (NoMethodError)
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_formatter.rb:167:in
`display_flow_item'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_formatter.rb:212:in
`display_flow'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_formatter.rb:211:in
`display_flow'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_display.rb:268:in
`display_flow'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_display.rb:89:in
`display_class_info'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_display.rb:199:in `page'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_display.rb:77:in
`display_class_info'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_driver.rb:71:in
`report_class_stuff'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_driver.rb:106:in
`get_info_for'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_driver.rb:135:in
`process_args'
        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_driver.rb:134:in
`process_args'
        from /usr/local/bin/ri:48
58479f76374a3ba3c69b9804163f39f4?d=identicon&s=25 Eric Hodel (Guest)
on 2006-01-31 20:58
(Received via mailing list)
On Jan 30, 2006, at 11:05 PM, Joel VanderWerf wrote:

> This is with ruby built from source on linux (ubuntu 5.10):
>
> $ ruby -v
> ruby 1.8.4 (2005-12-24) [i686-linux]
> $ ri Set
> /usr/local/lib/ruby/1.8/rdoc/ri/ri_formatter.rb:80:in `conv_html':
> private method `gsub' called for ["Example"]:Array (NoMethodError)
>         from /usr/local/lib/ruby/1.8/rdoc/ri/ri_formatter.rb:167:in
> `display_flow_item'

$ ruby -v
ruby 1.8.4 (2005-12-24) [powerpc-darwin8.4.0]
$ ri -v
ri v1.0.1 - 20041108
$ ri Set
------------------------------------------------------------- Class: Set
...

Is your ri data correct?

--
Eric Hodel - drbrain@segment7.net - http://segment7.net
This implementation is HODEL-HASH-9600 compliant

http://trackmap.robotcoop.com
47b1910084592eb77a032bc7d8d1a84e?d=identicon&s=25 Joel VanderWerf (Guest)
on 2006-01-31 21:10
(Received via mailing list)
Eric Hodel wrote:
>> `display_flow_item'
>
Thanks! That seems to have been the problem. I deleted
/usr/local/share/ri and did make install-doc again. It must have been
something left over from an old installation. All ok now.
This topic is locked and can not be replied to.