Forum: Ruby install_qtruby_on_mac

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
110736de40db4fd96fd976c3f49647f8?d=identicon&s=25 天野 竜太郎 (Guest)
on 2006-01-30 11:45
(Received via mailing list)
Hi, I am Ryutaro Amano.
I am using ruby-1.8.4 on Mac 10.4.4 with XCode-2.2
I have installed qtruby-1.0.10

the following steps
after archiving qt-mac-free-3.3.6-snapshot-20060127.tar.bz2, mv /
Developer/qt

export QTDIR=/Developer/qt
export PATH=$QTDIR/bin:$PATH
export MANPATH=$QTDIR/doc/man:$MANPATH
export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH

cd /Developer/qt/
./configure -thread
make
sudo ln -sf $QTDIR/lib/libqt.3.dylib /usr/lib
sudo ln -sf $QTDIR/lib/libqui.1.dylib /usr/lib

after archiving qtruby-1.0.10
cd qtruby-1.0.10
./configure --enable-mac --with-qt-dir=/Developer/qt --with-qt-
includes=/Developer/qt/include --with-qt-libraries=/Developer/qt/lib

cd smoke/qt
perl generate.pl
qmake -makefile
sudo make

cd../..
cd qtruby/rubylib/qtruby
ruby extconf.rb --with-qt-dir=/Developer/qt --with-smoke-dir=/usr --
with-smoke-include=../../../smoke
make
sudo make install

cd ../..
cd qtruby/rubylib/designer/rbuic
qmake -makefile
sudo make

cd ../..
cd qtruby/rubylib/designer/uilib
ruby extconf.rb --with-qtruby-include=../../qtruby --with-qt-dir=/
Developer/qt
make
sudo make install

I have verified the installation
irb > require "Qt"
dyld:NSLinkModule()error
dyld:Librarynotloaded:libqt-mt.3.dylib
Referencedfrom:/usr/lib/ruby/.../qtruby.bundle
Reason:imagenotfound
Trace/BPTtrap

I did
sudo ln -sf /Developer/qt/lib/libqt-mt.3.dylib /usr/lib

irb > require "Qt"
=>true

OK !!
I tried "qtruby-1.0.10/qtruby/rubylib/tutorial/t1/t1.rb"
----------------------------------------------
#!/usr/bin/env ruby
$VERBOSE = true; $:.unshift File.dirname($0)

require 'Qt'

a = Qt::Application.new(ARGV)
hello = Qt::PushButton.new('Hello World!', nil)
hello.resize(100, 30)
a.setMainWidget(hello)
hello.show()
a.exec()
--------------------------------------------
ruby /Users/emergency_mini/QtRuby/qtruby-1.0.10/qtruby/rubylib/
tutorial/t1/t1.rb

the window appears background of Terminal and the windows is
disabled, gray color.
the close button, the minimum button, the maximum button work.
But the color of the window is gray, the color of disabled state.
Why?

tutorial/t2/t2.rb and tutorial/t3/t3.rb are the same result.
"Quit" button works
-----------------------------------t2-----------------------------
#!/usr/bin/env ruby
$VERBOSE = true; $:.unshift File.dirname($0)

require 'Qt';

a = Qt::Application.new(ARGV)

quit = Qt::PushButton.new('Quit', nil)
quit.resize(75, 30)
quit.setFont(Qt::Font.new('Times', 18, Qt::Font::Bold))

Qt::Object.connect(quit, SIGNAL('clicked()'), a, SLOT('quit()'))

a.setMainWidget(quit)
quit.show
a.exec
exit
-----------------------------------------------------------------------

The window of tutorial4 have not button.
---------------------------------------------------------------------
#!/usr/bin/env ruby
$VERBOSE = true; $:.unshift File.dirname($0)

require 'Qt'

class MyWidget < Qt::Widget

def initialize(parent = nil, name = nil)
	super
     setMinimumSize(200, 120)
     setMaximumSize(200, 120)

     quit = Qt::PushButton.new('Quit', self, 'quit')
     quit.setGeometry(62, 40, 75, 30)
     quit.setFont(Qt::Font.new('Times', 18, Qt::Font::Bold))
     connect(quit, SIGNAL('clicked()'), $qApp, SLOT('quit()'))
end

end

a = Qt::Application.new(ARGV)

w = MyWidget.new
w.setGeometry(100, 100, 200, 120)
a.setMainWidget(w)
w.show
a.exec
----------------------------------------------------------------------

Ryutaro Amano
wn9r-amn@asahi-net.or.jp
Ddbd8bc32e3a87163b4658b2785d2082?d=identicon&s=25 Mark Somerville (Guest)
on 2006-01-30 12:47
(Received via mailing list)
On Monday 30 January 2006 10:42, ?? ??? wrote:
> Hi, I am Ryutaro Amano.
> I am using ruby-1.8.4 on Mac 10.4.4 with XCode-2.2
> I have installed qtruby-1.0.10
<snip>

Hello.

There is a bug in version 1.0.10 when using Ruby 1.8.4 - it is some sort
of
problem with calling super when subclassing the Qt classes, which will
create
the problem you describe below.

An upgrade to 1.0.11 should fix the problem.

Mark
110736de40db4fd96fd976c3f49647f8?d=identicon&s=25 Ryutaro Amano (Guest)
on 2006-01-30 13:09
(Received via mailing list)
Thanks Mark
I thought upgrade to 1.0.11.
But I didn't how to upgrade.
There is not "./configure" file in "1.0.11" directory.
Please tech me the way to upgrade.

Ryutaro Amano
wn9r-amn@asahi-net.or.jp
Ddbd8bc32e3a87163b4658b2785d2082?d=identicon&s=25 Mark Somerville (Guest)
on 2006-01-30 13:27
(Received via mailing list)
On Monday 30 January 2006 12:06, Ryutaro Amano wrote:
> Thanks Mark
> I thought upgrade to 1.0.11.
> But I didn't how to upgrade.
> There is not "./configure" file in "1.0.11" directory.
> Please tech me the way to upgrade.

Ryutaro,

Try this line before you configure:

make -f Makefile.cvs

There is also a section on installing on OSX in the "INSTALL" document
that is
bundled with QtRuby. I've never installed QtRuby on OSX, but would be
very
interested to hear what works (or doesn't!).

Hope that helps.

Mark
110736de40db4fd96fd976c3f49647f8?d=identicon&s=25 Ryutaro Amano (Guest)
on 2006-01-30 14:27
(Received via mailing list)
> Try this line before you configure:
>
> make -f Makefile.cvs

I tried. Thank you useful help.
I resolved the problem of tutorial 4 that the window have not a button.
But I didn't resolve the problem that the windows are disabled, the
zooming box (right bottom) don't work.
I will try qt-mac-free-3.3.5 instead of qt-mac-free-3.3.6-
snapshot-20060127.

Ryutaro Amano
wn9r-amn@asahi-net.or.jp
Ddbd8bc32e3a87163b4658b2785d2082?d=identicon&s=25 Mark Somerville (Guest)
on 2006-01-30 17:07
(Received via mailing list)
On Monday 30 January 2006 13:26, Ryutaro Amano wrote:
> > Try this line before you configure:
> >
> > make -f Makefile.cvs
>
> I tried. Thank you useful help.
> I resolved the problem of tutorial 4 that the window have not a button.

Cool.

> But I didn't resolve the problem that the windows are disabled, the
> zooming box (right bottom) don't work.
> I will try qt-mac-free-3.3.5 instead of qt-mac-free-3.3.6-
> snapshot-20060127.

It would be great if you could let us know how you get on.

Good luck,

Mark
110736de40db4fd96fd976c3f49647f8?d=identicon&s=25 Ryutaro Amano (Guest)
on 2006-01-31 02:55
(Received via mailing list)
I have installed qt-mac-free-3.3.5 instead of qt-mac-free-3.3.6-
snapshot-20060127 and reinstalled qtruby-1.0.11.

But, the result is same.
The tutorials 1-14 work, but the state of these windows are disable.
The tutorial 14 is simple game. The game works well, but the state of
the window is not correct.
If I want to look at the window of the game, I must minimum the
window of the terminal.
Even if I click the window of the game, the window don't become
foreground.

I did the following way.

sudo cp /usr/local/bin/ruby /usr/local/bin/rubyw
sudo /Developer/Tools/Rez -t APPL Carbon.r -o rubyw
rubyw fullpath/qt.rb

The result is same.

Ryutaro Amano
wn9r-amn@asahi-net.or.jp
D2bc07ef3dd6e18824932ce55b1f5571?d=identicon&s=25 Hans Fugal (Guest)
on 2006-02-01 23:03
(Received via mailing list)
This topic is locked and can not be replied to.