Forum: Ruby on Rails can't install model_security_generator

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
4005a47a8f2ceee49670b920593c1d52?d=identicon&s=25 Ben Munat (Guest)
on 2006-01-23 22:58
(Received via mailing list)
I'm trying to install Bruce Perens' ModelSecurity gem, but it keeps
asking me if I want to
install rails too (I have already installed rails). It exits if I say no
and crashes if I
say yes:

C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install
model_security_generator
Attempting local installation of 'model_security_generator'
Local gem file not found: model_security_generator*.gem
Attempting remote installation of 'model_security_generator'
Install required dependency rails? [Yn]  Y
c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:144:in `activate':
(Gem::LoadError)
RubyGem version error: rails(0.10.0 not >= 0.13.1)
         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:42:in
`require_gem'
         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:58:in
`install'
         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:56:in
`each'
         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:56:in
`install'
         from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:362:in
`install'
         from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:164:in `execute'
         from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:129:in `each'
         from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:129:in `execute'
         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/command.rb:49:in
`invoke'
         from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:90:in
`process_args'
         from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:63:in `run'
         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:9:in
`run'
         from c:/ruby/bin/gem:11

Hmm, seems my problem is worse than I thought:

"RubyGem version error: rails(0.10.0 not >= 0.13.1)"

How the heck do I have rails 0.10.0? I just ran "gem update rails" and
it seems satisfied:

C:\>gem update rails

C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" update rails
Upgrading installed gems...
Attempting remote upgrade of rails
Attempting remote installation of 'rails'
Successfully installed rails_analyzer_tools, version 1.1.0
Installing RDoc documentation for rails_analyzer_tools-1.1.0...
Attempting remote upgrade of rake
Attempting remote installation of 'rake'
Successfully installed rake, version 0.7.0
Installing RDoc documentation for rake-0.7.0...
All gems up to date

What am I missing?

thanks,

b
4005a47a8f2ceee49670b920593c1d52?d=identicon&s=25 Ben Munat (Guest)
on 2006-01-23 23:07
(Received via mailing list)
Ahhhhhhhhh! I tried to update my rails by uninstalling and
reinstalling... it uninstalled
but now it just acts like it's installing rails and doesn't:

C:\>gem install rails

C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails
Attempting local installation of 'rails'
Local gem file not found: rails*.gem
Attempting remote installation of 'rails'
Successfully installed rails_analyzer_tools, version 1.1.0
Installing RDoc documentation for rails_analyzer_tools-1.1.0...

and then:

C:\>cd ruby\projects

C:\ruby\projects>rails temptest
C:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:139:in `activate':
(Gem::LoadError)
Could not find RubyGem rails (> 0)
         from C:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:42:in
`require_gem'
         from c:/ruby/bin/rails:18


Crap.

b
132a94ca65959bda6c74fae54bff2425?d=identicon&s=25 Ezra Zygmuntowicz (Guest)
on 2006-01-23 23:53
(Received via mailing list)
Ben-

	Try this instead:

 > gem install rails --version=1.0.0 --include-dependencies

Cheers-
-Ezra

On Jan 23, 2006, at 2:08 PM, Ben Munat wrote:

> Successfully installed rails_analyzer_tools, version 1.1.0
>         from C:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:42:in
>> keeps asking me if I want to install rails too (I have already
>>         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:42:in
>> gem_commands.rb:164:in `execute'
>>         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:
>> Attempting remote installation of 'rails'
>> _______________________________________________
>> Rails mailing list
>> Rails@lists.rubyonrails.org
>> http://lists.rubyonrails.org/mailman/listinfo/rails
> _______________________________________________
> Rails mailing list
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails
>

-Ezra Zygmuntowicz
Yakima Herald-Republic
WebMaster
http://yakimaherald.com
509-577-7732
ezra@yakima-herald.com
4005a47a8f2ceee49670b920593c1d52?d=identicon&s=25 Ben Munat (Guest)
on 2006-01-24 01:15
(Received via mailing list)
Ezra Zygmuntowicz wrote:
> Ben-
>
>     Try this instead:
>
>  > gem install rails --version=1.0.0 --include-dependencies

Thanks for the answer, but:

C:\>gem install rails --version=1.0.0 --include-dependencies

C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails --version
1.0.0
--include-dependencies

ERROR:  While executing gem ... (OptionParser::InvalidOption)
     invalid option: --include-dependencies


So then I tried it without "--include-dependencies" and it did install:

C:\>gem install rails --version=1.0.0

C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails --version
1.0.0
Attempting local installation of 'rails'
Local gem file not found: rails*.gem
Attempting remote installation of 'rails'
Updating Gem source index for: http://gems.rubyforge.org
Successfully installed rails, version 1.0.0
Installing RDoc documentation for rails-1.0.0...
WARNING: Generating RDoc on .gem that may not have RDoc.

However, now I'm concerned that I don't have all the dependencies...
should I be worried?

b

PS: oh yeah:

C:\>ruby -v
ruby 1.8.2 (2004-12-25) [i386-mswin32]
4005a47a8f2ceee49670b920593c1d52?d=identicon&s=25 Ben Munat (Guest)
on 2006-01-24 01:33
(Received via mailing list)
Ben Munat wrote:
>
>
>
> However, now I'm concerned that I don't have all the dependencies...
> should I be worried?
>
> b
>
> PS: oh yeah:
>
> C:\>ruby -v
> ruby 1.8.2 (2004-12-25) [i386-mswin32]

I think I got it...

C:\>gem update rubygems

C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" update rubygems
Upgrading installed gems...
Updating Gem source index for: http://gems.rubyforge.org
Attempting remote upgrade of rubygems
Attempting remote installation of 'rubygems'
Successfully installed rubygems-update-0.8.11
Gems: [rubygems] updated

C:\>gem install rails --include-dependencies

C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails
--include-dependencies
Attempting local installation of 'rails'
Local gem file not found: rails*.gem
Attempting remote installation of 'rails'
Successfully installed rails-1.0.0


:-)

b
132a94ca65959bda6c74fae54bff2425?d=identicon&s=25 Ezra Zygmuntowicz (Guest)
on 2006-01-24 01:36
(Received via mailing list)
Ben-

	If your gem command does not recognize the --include-dependencies
command then you have an old version of rubygems. You need to update
your rubygems install:

 > gem update --system

	Then the --include-dependencies will work.

Cheers-
-Ezra

On Jan 23, 2006, at 4:15 PM, Ben Munat wrote:

> version 1.0.0 --include-dependencies
> C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails --
> dependencies... should I be worried?
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails
>

-Ezra Zygmuntowicz
Yakima Herald-Republic
WebMaster
http://yakimaherald.com
509-577-7732
ezra@yakima-herald.com
This topic is locked and can not be replied to.