Forum: Rails Engines "script/plugin install" help with svn site errors?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
A012eb524ad9f0dfe44f0fa2237eaa64?d=identicon&s=25 Brad (Guest)
on 2006-01-18 18:38
Hi,

I've downloaded and used the login_engine and am now working on the
user_engine--login_engine worked fine, btw--I got the following errors
(below) when running the install (same thing happened for login_engine,
I just didn't report it then, as it seemed to work just fine--and I
assume the user_engine will too).

Looks like perhaps the svn.protocool.com and svn.substance-it.co.uk
sites both are having problems of some kind.  (I don't really know how
the discover or install commands work for script/plugin, btw.)  Is there
a way to 'remove' those two sites from the list of sites that are
checked when an install is done?

Or do I just ignore these messages and be happy that I got my revision
exported at all?

(Maybe just a sentence or two on how discover and install work, in
general, might help me and others learn what's happening here.  Or point
me to a 'doc' URL that explains them?  And yes, I probably need to go
read through the script/plugin stuff at some point.)

Thanks,
Brad

Here is my output, with the actual install excised (I also show my
latest discover from today, first--last time I ran it was about a week
ago, just fyi...)--and by the way, when I ran it the first time I had to
put about 25 "Y" answers in--maybe that was my mistake?  Should we know
where we want to download from and/or only say "Y"es to one site?
(Clearly I'm somewhat clueless about this process! :-)

c:\cd\work\svn\myproj>ruby script/plugin discover
Add http://rubyforge.org/var/svn/laszlo-plugin/rails/plugins/? [Y/n] y
Add http://filetofsole.org/svn/public/projects/rails/plugins/? [Y/n] y
Add http://www.eric-stewart.com/svn/rails/plugins/? [Y/n] y

c:\cd\work\svn\myproj>ruby script/plugin discover

c:\cd\work\svn\myproj>ruby script/plugin install user_engine
svn: PROPFIND request failed on '/rails/plugins'
svn: PROPFIND of '/rails/plugins': 403 Forbidden
(http://svn.protocool.com)
svn: PROPFIND request failed on '/public/plugins'
svn: PROPFIND of '/public/plugins': Could not resolve hostname
`svn.substance-it
.co.uk': The requested name is valid and was found in the database, but
it does
not have the correct associated data being resolved for.
(http://svn.substance
-it.co.uk)

[ . . . ]

Exported revision [nnn].
05d703f649ef1d07e78d7b479fb4c4ac?d=identicon&s=25 James Adam (Guest)
on 2006-01-18 18:45
(Received via mailing list)
You can remove these sites as login sources. On Linux/Mac the list of
plugin source URLS is stored in ~/.rails-plugin-sources - I'm not sure
about Windows. Anyway, remove the offending sites and they won't be
checked for plugins. The message is pretty annoying.

- james
A012eb524ad9f0dfe44f0fa2237eaa64?d=identicon&s=25 Brad (Guest)
on 2006-01-18 19:37
Thanks James!  Worked fine.

James Adam wrote:
> ... On Linux/Mac the list of
> plugin source URLS is stored in ~/.rails-plugin-sources - I'm not sure
> about Windows. ...

Just for thoroughness, in case someone else doesn't want to search their
Windows installation for this file, the place where the
.rails-plugin-sources file can be found on Windows (XP) is:

rootdrive:\Documents and Settings\<your computer or user name directory>

So, for example, mine was found here:

C:\Documents and Settings\Brad\.rails-plugin-sources

Cheers,
Brad
78d45b303250a077fc65fd61e00277ed?d=identicon&s=25 Jon Lim (Guest)
on 2006-01-19 11:06
(Received via mailing list)
script/plugin --help

script/plugin unsource therubbishurl

On 18/01/06, Brad <ruby-forum@likethesky.com> wrote:
> the discover or install commands work for script/plugin, btw.)  Is there
>
> c:\cd\work\svn\myproj>ruby script/plugin discover
> svn: PROPFIND request failed on '/public/plugins'
> Exported revision [nnn].
>
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> engine-users mailing list
> engine-users@lists.rails-engines.org
> http://lists.rails-engines.org/listinfo.cgi/engine...
>


--
http://www.snowblink.co.uk/
This topic is locked and can not be replied to.